VirtualBox

Ticket #1033 (new defect)

Opened 6 years ago

Last modified 6 years ago

Guest USB Audio fails running on windows host

Reported by: MikeP Owned by:
Priority: major Component: USB
Version: VirtualBox 1.5.4 Keywords: USB Audio Sound
Cc: Guest type: other
Host type: other

Description

Problem: On Windows hosts, USB Audio devices are correctly identified and installed in the guest but there is no sound in either direction. This happens with Windows and Linux guests.

Description: When connecting the USB device (Plantronics headset in this case) one can see the USB activity light flashing when there should be sound, but nothing is heard. When using the volume control on the headset, the volume slider moves in the guest - so communication is definitively happening. All hardware is recognized and correctly identified/installed in the guest.

Host is Vista x64, attempted Win XP & Vista and openSUSE Linux (clean installs) with no success.

References: It appears this can be made to work on Linux hosts with some tweaking, but others have the same problem on win hosts.  http://vbox.innotek.de/pipermail/vbox-users/2007-April/001441.html  http://forums.virtualbox.org/viewtopic.php?t=3281  http://forums.virtualbox.org/viewtopic.php?t=3335  http://forums.virtualbox.org/viewtopic.php?t=3138

Logs: Three logs are attached with different scenarios:

  1. Attaching the device once XP is logged in
  2. Attaching the device before starting the guest machine
  3. Disabling EHCI (here the USB activity light flashes whenever there should be sound).

Attachments

VBox.logs.zip Download (23.8 KB) - added by MikeP 6 years ago.
Logs

Change History

Changed 6 years ago by MikeP

Logs

comment:1 Changed 6 years ago by frank

  • Component changed from other to USB
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use