VirtualBox

Ticket #10326 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

VBoxService.exe - Application Error (v 4.1.10) => Fixed in SVN

Reported by: Simon Said Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.10 Keywords: VBoxService
Cc: Guest type: Windows
Host type: Windows

Description

After upgrading to v4.1.10 and installing the corresponding Guest Additions on a XP SP3 guest I am now getting an application error (see screenshot) message when shutting it down. After restoring a backup of the .vbox and .vdi files that had the previous version of the Guest Additions (v4.1.8-75467) the crash does not occur.

Simon

Attachments

VBox.log Download (74.9 KB) - added by Simon Said 2 years ago.
VBoxService Crash.png Download (25.4 KB) - added by Simon Said 2 years ago.
VBoxServiceLogs.zip Download (23.3 KB) - added by Pender 2 years ago.
VBoxService logs as requested

Change History

Changed 2 years ago by Simon Said

Changed 2 years ago by Simon Said

comment:1 Changed 2 years ago by eeleigh

I am getting the same thing since upgrading to 4.1.10 as well, but only on 1 of 3 Virtual Boxes running XPProSP3. I tried uninstalling the new Guest Box Additions and it went away. I reinstalled and it came back. My other two Virtual XP Boxes are setup exactly the same, but no problems.

comment:2 Changed 2 years ago by Pender

Yes, I am seeing the same thing as well after I upgraded to 4.1.10. Running XP SP3 Guest on Vista 64bit Host. The problem is seen when shutting down the VM.

comment:3 Changed 2 years ago by pentagonik

Tried to reproduce it on my XPSP3 guest here but no luck so far. Could you please do the following in the XP guest:

In the guest, open regedit.exe as Administrator and add/edit the following keys:

HKLM\SYSTEM\CurrentControlSet\Services\VBoxService\ImagePath = "system32\VBoxService.exe -vvvv --logfile c:\VBoxService.log" (REG_EXPAND_SZ)

After the registry modification were made the guest needs to be restarted.

Please then attach the VBoxService.log file(s) (will be written to C:\ on the guest) to this defect. Thanks!

Changed 2 years ago by Pender

VBoxService logs as requested

comment:4 Changed 2 years ago by frank

We think we fixed the problem. Could you update your Guest Additions using  this iso image and verify that the crash is fixed? Thank you!

comment:5 Changed 2 years ago by frank

Please disregard my last comment, problem still there.

comment:6 Changed 2 years ago by frank

  • Summary changed from VBoxService.exe - Application Error (v 4.1.10) to VBoxService.exe - Application Error (v 4.1.10) => Fixed in SVN

Finally found and fixed the problem. Fix in the next maintenance release.

comment:7 follow-up: ↓ 8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.1.12.

comment:8 in reply to: ↑ 7 Changed 2 years ago by clb3

Replying to frank:

Fixed in 4.1.12.

Installed update. Still have above error on exit. Do I need to re-install guest services?

comment:9 Changed 2 years ago by frank

Yes, to fix that VBoxService.exe problem (which is a guest service) you need to update the Guest Additions to 4.1.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use