Opened 12 years ago

Last modified 7 years ago

#10317 new defect

Windows 8 Host: No network adapters after resume from sleep

Reported by: Andrew Owned by:
Component: network/hostif Version: VirtualBox 4.1.8
Keywords: windows 8, sleep, bridge adapter Cc:
Guest type: other Host type: Windows


I am running Oracle VirtualBox 4.1.8 r75467 on a Thinkpad T510. When I put my computer to sleep, the only way to get functioning NIC's on my host after resume is to go into device manager, uninstall the NIC and then scan for hardware changes to re-install the NIC. I disabled the VirtualBox Bridged Network Driver on each NIC and I no longer have this problem.

Change History (17)

comment:1 by jmbpiano, 12 years ago

I have the same exact problem ever since I installed VB 4.1.8 on my Gateway FX6800-11. Sleep or Hibernate will always cause the NIC to stop working. In one instance it wasn't working after a normal shutdown. An alternative method of temporarily fixing the problem is to run Windows Network Diagnostics and allow it to automatically repair issues.

My on-board NIC is an Intel 82567LF-2 Gigabit Network device. Switching from the Microsoft provided drivers to the drivers available from the Gateway support page made no difference.

Disabling the bridged network driver as the OP suggested appears to work.

comment:2 by vbaderks, 12 years ago

I have the same problem on 2 different machines with Windows 8 Consumer Preview installed. Workaround by disabling the Bridged Network Driver works.

Due to the fact that the hosted network that virtualbox also installed is always not connected Windows 8 also shows always 'a not connected' icon in the lower right corner. I had to disable the 'hosted' network to resolve that.

comment:3 by Andrew, 12 years ago

I can confirm this issue exists in 4.1.10 r76836 as well.

comment:4 by cpqalve, 12 years ago

I can confirm the issue exists in 4.1.10 as well.

comment:5 by Andrew, 12 years ago

This issue still exists in 4.1.12 r77245.

comment:6 by LeoStorm85, 12 years ago

Issue still existing in 4.2.0 r80737

comment:7 by Andrew, 12 years ago

Still a problem. Windows 8 Enterprise and VirtualBox 4.2.4 r81684.

Last edited 12 years ago by Andrew (previous) (diff)

comment:8 by Andrew, 12 years ago

If you need to use the bridged adapter on Windows 8 and you also need sleep/hibernate on your host, you can always disable and re-enable the NIC after resuming. I know Microsoft did a lot of work to the network stack in Windows 8 to speed up reconnecting upon resume which probably led to the regression. Below is how I automated this so I didn't have to screw with it anymore.


I created a powershell script that automates this process on a schedule. The trick was to comb the System Event Log for Informational event ID 1 where the source is Power-Troubleshooter. Once I found that, I right-clicked and added a task. When the event is fired, my script is triggered and disables all physical, enabled nics before re-enabling them.


gwmi Win32_NetworkAdapter -EnableAllPrivileges | ? { $_.PhysicalAdapter -and $_.NetEnabled } | % { $_.Disable(); $_.Enable() }

Seems to work thus far. It is obviously sub-optimal but at least I don't have to manually carry out the tasks any longer and I can use my bridged adapter on my laptop.

Please fix so I can remove this hack/workaround/bandaid.

Last edited 12 years ago by Andrew (previous) (diff)

comment:9 by mahop, 11 years ago

I also have this Problem. But I have it also with other Programms adding Network Adapters... Like the Microsoft Network Monitor... Looks like it is a Windows 8 problem...???

comment:10 by anshul makkar, 11 years ago

Is there any other network filter(antivirus etc) driver installed apart from vboxnetflt driver in the problematic scenario.

in reply to:  10 comment:11 by Andrew, 11 years ago

No. Out of the box Windows 8.

Replying to anshul makkar:

Is there any other network filter(antivirus etc) driver installed apart from vboxnetflt driver in the problematic scenario.

comment:12 by mitrov, 11 years ago

I am having the same problem with VB 4.2.16, Windows 8.1 new install and Broadcom neXtreme adapter.

Last edited 11 years ago by mitrov (previous) (diff)

comment:13 by billsey, 11 years ago

I'm seeing the problem with the latest Virtual Box (4.3.2) when the computer is restarted. I'm not using sleep or hibernate but any reboot has the issue. It looks like the VB Host-Only Network is getting initialized before the physical adapter, and then gets in the way of the physical adapter to start.

comment:14 by c0nsaw, 11 years ago

I am also having this issue, nothing I do will help reconnect my pc to internet. I have tried lots of workarounds, even system restore wont get me back to a working connection. I have only recently started using vagrant and vb to spin up vm's for learning. I have had to re-install windows several times to get back working again, talk about a sledge hammer to a nut (latest VB 4.3.x, with ext pack. Win 7 pro x64)

Last edited 11 years ago by c0nsaw (previous) (diff)

comment:15 by bulrush, 10 years ago

This problem still exists in Virtualbox 4.3.12. Vbox 4.3.14 doesn't run the guest (Ubuntu) at all.

Host: Windows 8.0 on HP Envy 700-074 Guest: Ubuntu 14.04.1 server

Detailed specs via Speccy available on request.


  • Install Virtualbox 4.3.14 on Windows 8. Then installed Ubuntu 14.04.1 desktop.
  • Found Vbix does not run the guest OS (Ubuntu) at all.
  • I was also getting an error about piix4.
  • Uninstalled Vbox, rebooted PC.
  • Installed Vbox 4.3.12. Installed Ubuntu 14.04.1 server this time (it's smaller and does not include the desktop)
  • My keyboard puts PC into suspend mode, where the memory is written to disk. When I come out of suspend, there is no network connection to the internet.
  • Reboot PC and internet works fine.
  • Try "sleep" mode, which doesn't completely power down PC, come out of sleep mode, and internet works fine.
  • I never had a problem before installing Virtualbox.

comment:16 by jaydouglass, 9 years ago

I tried the above remedies but none worked on Windows 8.1 / vbox 4.3.22.

Clicking 'Scan for hardware changes' in Device Manager added the network adapter back to my devices. I'm working on a script to do this automatically.

comment:17 by Andrew_885, 7 years ago

Same here. Tried to set up new machine for development, but network adapters disappeared after resuming from sleep mode.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use