VirtualBox

Ticket #10310 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Creating multiple NICs from command line does not work properly

Reported by: Perryg Owned by:
Priority: major Component: network
Version: VirtualBox 4.1.8 Keywords: CLI network
Cc: Guest type: Linux
Host type: Linux

Description

Creating a new guest and assigning two NICs, one set to host-only and one set to Bridged does not put the entries in the right slot. It puts them both in the slot0 and none in slot1.

Start the VMM and enter the network settings and click OK, it actually fixes this by adding an entry to slot1 for the bridged network, but leaves the entry in slot0. Not much good for those that don't have X.

Conversation was here:  https://forums.virtualbox.org/viewtopic.php?f=1&t=48353

What did I miss?

Sorry no log since one is not generated.

Change History

comment:1 Changed 2 years ago by Paul Hoffman

Related to this problem: even with the entry in slot1 filled in correctly as "eth0", you cannot start this VM in the GUI without first running "Settings", then clicking "OK". However, without doing that, you *can* run the VM from VBoxManage with --type headless.

comment:2 Changed 2 years ago by klaus

To me this looks like a typo in the commands you use for setting up the VM.

comment:3 Changed 2 years ago by Perryg

Yes you are right. I missed it not once but three times. Sorry for the noise.

Please close the ticket.

comment:4 Changed 2 years ago by klaus

  • Status changed from new to closed
  • Resolution set to invalid

comment:5 Changed 2 years ago by ankit

I am also facing the same issue. I tried with --type headless too, but still getting the same error.

Waiting for VM "su" to power on...

VBoxManage: error: Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (VERR_INTNET_FLT_IF_NOT_FOUND).

VBoxManage: error: Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND)

VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Console, interface IConsole, callee

My VirtualBox version is 4.1.8. I also tried with 4.1.10, 4.0.10 and 3.2.12. It didn't work for me.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use