VirtualBox

Ticket #10309 (new defect)

Opened 3 years ago

Last modified 5 months ago

USB is busy with a previous request [E_INVALIDARG (0x80070057)]

Reported by: Jacky Owned by:
Priority: major Component: USB
Version: VirtualBox 4.1.8 Keywords: USB E_INVALIDARG busy
Cc: Guest type: Windows
Host type: Windows

Description

Hi, I still have problems with connecting my USB device on this Win7-64bit host to a WinXP SP3 guest in 4.1.8 with usb_extension 4.1.8 and guest additions 4.1.8.

Connecting some usb flash drives succeeds but connecting my USB-to-CAN - device from peak-systems ( more info) is not working. In earlier versions I got a message when starting the guest like "Virtualbox USB is installing..." and after the next complete restart of my computer the device was working. But now I don't get the windows tray message "Virtualbox USB is installing..." and if I want to connect my usb device while vm is running I get the error

Das USB-Gerät VER1:PEAK    
VER2:02.8.01        
DAT :06.05.2004
TIME:09:35:37
                             ... [1C11] konnte nicht an die virtuelle Maschine Windows XP gebunden werden.

USB device 'VER1:PEAK    

VER2:02.8.01        

DAT :06.05.2004

TIME:09:35:37

                             ...' with UUID {2fb58d0c-81b4-4505-9984-a67bfc272a87} is busy with a previous request. Please try again later.

Fehlercode:E_INVALIDARG (0x80070057)
Komponente:HostUSBDevice
Interface:IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee:IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

USB-filters are set correctly, as already mentioned other usb mass storages are working. On my host this peak usb device is running with latest drivers and all seems to work.

I've been searching already for some hours in google and had a look at #3033 and #5343 and  Forums but nothing solved it until now.

Is there a way to find a solution? I don't want to reinstall earlier versions... Is there a problem to disconnect the device from host because it's busy?

Thanks for your help

Attachments

Windows XP MRS-2012-03-06-18-07-34.log Download (82.7 KB) - added by Jacky 3 years ago.
Windows XP-2012-03-06-19-13-45.log Download (85.5 KB) - added by Jacky 3 years ago.
Windows XP MRS-2012-03-06-18-07-34.2.log Download (82.7 KB) - added by Jacky 3 years ago.
Windows XP-2012-03-06-18-09-28.log Download (85.4 KB) - added by Jacky 3 years ago.

Change History

Changed 3 years ago by Jacky

Changed 3 years ago by Jacky

Changed 3 years ago by Jacky

Changed 3 years ago by Jacky

comment:1 Changed 3 years ago by andreaso

I am having the same problem, i.e. device busy. I am running VirtualBox 4.1.10 on Mac OS 10.7.3 with Windows XP SP1 as guest. I do not have any UpperFilters entry in the guest Registry. From the beginning (2.5 years ago) tested USB devices worked perfectly. Today only my mouse is recognized. Most important the printer cannot be recognized in any way I have tested. It stopped totally working with the upgrade to 4.1.10. An earlier degradation was that the native driver (HP 2025 PS) could not be used, but a generic HP ColorLaserJet PS driver could be used. If accessed from the Mac host OS, I cannot log on to the printer with any Mac user account. Is there anyway to log exactly what is going on?

comment:2 Changed 3 years ago by andreaso

Virtual Box 4.1.12 with the Extension Pack solved my problem! Both for USB Printer and USB Flash memory. Thanks.

comment:3 Changed 3 years ago by adhome

Go in filter and edit. You will see some information from this device. How is the serial number?

Perhaps my problem: https://www.virtualbox.org/ticket/10537

Version 0, edited 3 years ago by adhome (next)

comment:5 Changed 13 months ago by tjs211

I had a similar issue sometime back. What worked for me was to remove all text from the 'Product' field in the usb filter.

comment:6 Changed 6 months ago by T Kamizi

Hi everyone, I have had the same problem and I tried with two different USB 3.0 devices. The thing is, I think that was the problem, because when I changed to USB 2.0 it worked immediately (although you need to have the USB 2.0 support enabled before booting your VM).

So if nothing else works for your USB 3.0, try a USB 2.0 device instead! :)

PS. All my USB ports in my laptop are USB 3.0...

comment:7 in reply to: ↑ description Changed 5 months ago by aball

As far as I can tell, USB just doesn't work properly in VB (at least, not in the current version, on my hardware) I wasted most of a day trying to get two different mass storage devices to mount. Eventually gave up and tried VMWare Player - worked first time, no messing about with filters, both devices switchable between Host and Guest at will, with no other changes necessary - now I can just get on with the job instead of trying to get tools to do what they promise. Even if I have to pay a little for this, I will do so (currently on trial version) This problem lets VB down badly - fix it guys !

Replying to Jacky:

Hi, I still have problems with connecting my USB device on this Win7-64bit host to a WinXP SP3 guest in 4.1.8 with usb_extension 4.1.8 and guest additions 4.1.8.

Connecting some usb flash drives succeeds but connecting my USB-to-CAN - device from peak-systems ( more info) is not working. In earlier versions I got a message when starting the guest like "Virtualbox USB is installing..." and after the next complete restart of my computer the device was working. But now I don't get the windows tray message "Virtualbox USB is installing..." and if I want to connect my usb device while vm is running I get the error

Das USB-Gerät VER1:PEAK    
VER2:02.8.01        
DAT :06.05.2004
TIME:09:35:37
                             ... [1C11] konnte nicht an die virtuelle Maschine Windows XP gebunden werden.

USB device 'VER1:PEAK    

VER2:02.8.01        

DAT :06.05.2004

TIME:09:35:37

                             ...' with UUID {2fb58d0c-81b4-4505-9984-a67bfc272a87} is busy with a previous request. Please try again later.

Fehlercode:E_INVALIDARG (0x80070057)
Komponente:HostUSBDevice
Interface:IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee:IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

USB-filters are set correctly, as already mentioned other usb mass storages are working. On my host this peak usb device is running with latest drivers and all seems to work.

I've been searching already for some hours in google and had a look at #3033 and #5343 and  Forums but nothing solved it until now.

Is there a way to find a solution? I don't want to reinstall earlier versions... Is there a problem to disconnect the device from host because it's busy?

Thanks for your help

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use