VirtualBox

Ticket #10306 (closed defect: fixed)

Opened 2 years ago

Last modified 20 months ago

Windows 8 Consumer Preview VM stops responding when doing File IO (ICH9 only)

Reported by: Andre.Ziegler Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

When an application does some IO (file, network) the VM freezes and nothing happens for 1 or 2 minutes.

Attachments

VBox.log Download (63.5 KB) - added by Andre.Ziegler 2 years ago.

Change History

Changed 2 years ago by Andre.Ziegler

comment:1 follow-up: ↓ 2 Changed 2 years ago by dmashal

I can reproduce this bug it seems a graphics driver bug with the WDDM driver. I noticed dwm.exe using a lot of I/O and having a lot of page fault.

After a minute or 3 sending the guest a ctrl+alt+del will get the display back and Windows 8 CPU will start working again, for a few minutes until the problem happens again.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 4 Changed 2 years ago by misha

Replying to Andre.Ziegler and dmashal: Could you give the exact use-case so that we can reproduce the problem here?

comment:3 Changed 2 years ago by dmashal

Just install Windows 8 consumer preview on Win7 x64 host.

DVD must be in IDE mode to boot installer.

After install of Win 8 CP, install guest additions using WDDM driver (say no to using direct 3d) and reboot.

Then use windows for a few minutes, try and access system settings, configure the system as a normal user would and you will see the problem.

comment:4 in reply to: ↑ 2 Changed 2 years ago by Andre.Ziegler

Replying to misha:

Replying to Andre.Ziegler

Could you give the exact use-case so that we can reproduce the problem here?

for me it happens when I try to start IE10. In this case the VM simply hangs for a while and you can't do anything.

comment:5 Changed 2 years ago by dmashal

It can be anything. Try changing setting in control panel, or changing system settings, etc. It's something either with dwm.exe or svchost.exe windows host process.

comment:6 Changed 2 years ago by Perryg

Try it with PIIX3 instead of ICH9 chipset.

comment:7 Changed 2 years ago by Andre.Ziegler

what should I change?

I also think it is more DWM/GPU related. Today the VM freezed for over 2 minutes while running WinSAT.

comment:8 Changed 2 years ago by Andre.Ziegler

any news? The VM freezes so often that it makes no fun.

comment:9 Changed 2 years ago by misha

Does it help if you assign 1 CPU to you VM instead of 2?

comment:10 Changed 2 years ago by Andre.Ziegler

no, this doesn't matter :(

comment:11 Changed 2 years ago by Andre.Ziegler

ok, Perryg was right. I changed the chipset to PIIX3 in the VM settings and now Win8 works fine. I have no idea why I selected ICH9.

comment:12 Changed 2 years ago by Perryg

Once bitten twice shy as they say.

I have not been able to reliably use ICH9 for a long time, but I still try on occasion.

comment:13 Changed 2 years ago by frank

  • Summary changed from Windows 8 Consumer Preview VM stops responding when doing File IO to Windows 8 Consumer Preview VM stops responding when doing File IO (ICH9 only)

comment:14 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 4.1.20. Please reopen if still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use