VirtualBox

Ticket #10276 (closed defect: duplicate)

Opened 2 years ago

Last modified 20 months ago

Occasional BSOD upon shutting down a VM

Reported by: B.Sam Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.1.8 Keywords: BSOD
Cc: Guest type: other
Host type: Windows

Description

Hey guys,

So here's the story: I was using v3.2 and older versions with no problem for months( host: windows server 2003 x86, guests: mostly xp x86) . then i decided to upgrade to the latest version (4.1.6 at the time i think). one time, while i was installing win7 x64 as a guest OS, the host froze and i had to restart it. that was the first time ever that i had such a problem with VBox. but not the last time. but first a little background on how i use VBox:

i usually run VBox through terminal service. by connecting remotely to the host and running the VM. there are a lot of times that 2 different VM's are running under 2 different accounts/sessions (which both are terminal service sessions). now this might have nothing to do with the problem, but i thought it was worth mentioning. sometimes i noticed, after shutting down a VM, the system fails to completely shut it down. VBox manager stuck with a black screen and status of "stopping..." or something like that. i couldn't close the window and if i tried to force it via task manager, i would get BSOD. i pretty much tried anything i could think of but it didn't help. most of the times, the VM shuts down properly but every once in a while, it either gets stuck or gives me a BSOD right away. sometimes, i can also see this in the log:

00:03:05.295 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
00:03:05.982 Changing the VM state from 'DESTROYING' to 'TERMINATED'.

Also, sometimes the VM shuts down but if i try to restore a snapshot, its unable to access it and i practically lose the whole VM, with VBox manager giving error about not finding the snapshot. every time i have to open the .xml file of that VM and manually edit out the snapshot so it could start to work again. i even uninstalled the whole VBox once, tried to find any trace of left-over entries in the registry, removed them and installed the latest version ( 4.1.8 ), disabled the usb support and host-only network support in installation options, but it's still the same.

I thought it got something to do with graphical interface. so i started running my VMs via VBoxHeadless. with VBoxHeadless, i dont see that error in the log anymore but still every once in a while, upon shutting down a VM, i get BSOD. i don't really remember, but i think even by running a single VM, i still got BSOD once. which suggests its not about running different VMs under different sessions. i have attached the minidumps. i have also attached vbox.log files for two of those minidumps (one from v4.1.6 and other v4.1.8). the error codes in minidumps are different each time . the first minidump might be for the time when i was trying to install win 7 x64 as i said earlier. ( to be honest, i can't really recall whether i got BSDO or the system completly froze. cause in case of the latter, minidump, wouldnt be there). but nevertheless, all of those BSODs are originated from VBox and probably except the first one, the rest happened exactly after shutting down a VM.

If there's anything else i could provide, please tell me know.

Regards,

Attachments

dumps_logs.zip Download (92.6 KB) - added by B.Sam 2 years ago.
VBox.log Download (64.0 KB) - added by B.Sam 2 years ago.
VBox.log.1 Download (105.7 KB) - added by MarkCranness 2 years ago.
Guests VM's.zip Download (121.2 KB) - added by AWsum+ 23 months ago.
Logs from the guests OS's (Windows and Linux)
Windows minidump files.zip Download (505.0 KB) - added by AWsum+ 23 months ago.
Mini061212-01.dmp Download (69.5 KB) - added by infomaniac50 23 months ago.
Window Server 2003 R2 SP2
infomaniac50 vbox log.log Download (7.2 KB) - added by infomaniac50 23 months ago.

Change History

Changed 2 years ago by B.Sam

comment:1 Changed 2 years ago by B.Sam

I also got full Kernel memory dump (324 MB) for the last BSOD. since i suspect it might contain sensitive data, i can't send it publicly. but if developers think its needed, im able to send it to them.

Last edited 2 years ago by B.Sam (previous) (diff)

comment:2 in reply to: ↑ description Changed 2 years ago by B.Sam

If there's anything else i could provide, please tell me know.

I wish i could modify my description. even though its a small change, but sometimes even small changes matter. anyway, the line should read:

If there's anything else i could provide, please let me know.

Last edited 2 years ago by B.Sam (previous) (diff)

comment:3 Changed 2 years ago by B.Sam

Got another sweet BSOD last night! unfortunately, it seems the system failed to create a memory dump since it doesn't seem to be there. this BSOD, like other ones, exactly happened when the VM was supposed to terminate. i was looking at the task manager when this happened and although i'm not 100% sure, but it seemed to me VBoxSVC.exe was terminated while VBoxHeadless.exe was still running. I might be wrong of course.

I will attach the Vbox.log file. I'm also planning to downgrade to v3.2 in the coming week. since the VBox is running on a quite critical server, i can not risk it anymore.

Regards,

Changed 2 years ago by B.Sam

Changed 2 years ago by MarkCranness

comment:4 Changed 2 years ago by MarkCranness

Related (based on error message in logs).

Using Close Virtual Machine > Save machine state to close and save a VM. Saving save state file stalls at 100% indicated, and VM can't be stopped or paused or anthing. See log attacched as VBox.log.1

comment:5 Changed 2 years ago by B.Sam

Is there any news on this? I've been using 3.2.14 for the past 2 months without a single bsod.

comment:6 Changed 23 months ago by AWsum+

I'm having exactly the same problem. I regularly get these BSOD in the host OS (which is Windows XP with SP3 AND Windows 7 with SP 1) when I shutdown a VM. It mostly (not always) happens when I have more then 4 VM's running and I shutdown one of them. In 95 percent of the cases where I get a BSOD when running VirtualBox, it happens when I shutdown a machine. Sometimes it also happens when i'm working on the VM, but not very often.

I provided all logs that I could find. If you need more information, please don't hesitate to ask. :)

Oh. I almost forgot. It happens on Virtualbox 4.1.8, 4.1.10, 4.1.12, 4.1.14 and 4.1.16. in WinXP and Win7

Changed 23 months ago by AWsum+

Logs from the guests OS's (Windows and Linux)

Changed 23 months ago by AWsum+

Changed 23 months ago by infomaniac50

Window Server 2003 R2 SP2

Changed 23 months ago by infomaniac50

comment:7 Changed 23 months ago by infomaniac50

Here is my two cents. Analyzed the dump file and it looks like a BAD_POOL_HEADER error in vboxheadless.exe.

I run virtual box as a web service while using phpvirtualbox to access it over the network. Also it crashed as soon as one of my VMs was about to poweroff. I am also using the latest version of VirtualBox.

EDIT: My problem may actually be a bad ram issue on the host. Just got another dump check and in both instances it is a failure to read from the same address in memory.

Last edited 23 months ago by infomaniac50 (previous) (diff)

comment:8 Changed 22 months ago by frank

The problem with restoring a snapshot during VM shutdown is a duplicate of #10491.

comment:9 follow-up: ↓ 10 Changed 21 months ago by virtualguy

Here too:

Random BSOD's when shutting down VM or saving its state, while at least one other machine is running.

Version: 4.1.x in virtually any hardware emulation combination
Host: both XPsp3 and 7sp1
Guest: independent of OS

comment:10 in reply to: ↑ 9 Changed 20 months ago by virtualguy

I have created a new Ticket https://www.virtualbox.org/ticket/10867 because AWsum+'s and my observations are slightly different from OP. I have also attached Dumps and Logs to the ticket. Here is a quote about whats happening:

Random IRQ_NOT_LESS_OR_EQUAL, BAD_POOL_HEADER & MEMORY_MANAGEMENT BSOD's occur on Win hosts when shutting down a VM or saving its state, while at least one other machine is running.

Tested on both XPsp3(32bit) and 7sp1(32bit) on two different computers with all 4.1 and 4.2 versions.

To reproduce: Start 2 VMS running only are bare live linux. Let one running, while saving the state / resume the other. Repeat. It might take upto 10 tries until host BSOD occurs.

comment:11 Changed 20 months ago by virtualguy

I found another related bug report https://www.virtualbox.org/ticket/10736

comment:12 Changed 20 months ago by michaln

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #9897. Note that it only happened on 32-bit Windows hosts (and the effect was a host crash, not a hang). And it only affected version 4.1.x, not 4.0.x or older releases.

comment:13 Changed 20 months ago by B.Sam

Anyone who's done any kernel debugging, knows that these kinda unpredictable bugs are the hardest ones to find. And yet you've managed to identify and fix it with the little information you had. My hat goes off to you. Thank you and well done

Last edited 20 months ago by B.Sam (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use