VirtualBox

Ticket #10266 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Segmentation Fault during startup on Mac OSX 10.7.3

Reported by: sflemming Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.1.8 Keywords:
Cc: sf@… Guest type: other
Host type: Mac OS X

Description

When I try to start Virtual Box on my freshly installed Mac OSX 10.7.3 I get a Segmentation Fault: 11.

Reinstalling and using an older Version (4.0.16) does not solve the problem.

Running virtualbox using gdb VirtualBox.app gives me a prompt where I can enter my password, when I enter it gdb outputs:

VirtualBox: Error -10 in SUPR3HardenedMain! VirtualBox: Effective UID is not root (euid=501 egid=20 uid=501 gid=20)

When I start Virtual Box with sudo gdb VirtualBox.app it starts fine.

I'm not sure if it is related but the VirtualBox installer shows that all program parts will consume 0kB.

Attachments

vbox-installer.png Download (126.0 KB) - added by sflemming 2 years ago.
Screenshot of installer

Change History

Changed 2 years ago by sflemming

Screenshot of installer

comment:1 Changed 2 years ago by michaln

The installer isn't showing anything unusual. It's an upgrade so the installer is just saying no additional disk space will be needed.

comment:2 Changed 2 years ago by sflemming

A deeper investigation showed that VBoxSVC could not be started due to the error:

VBoxSVC: error: Failed to initialize XPCOM! (rc=NS_ERROR_FAILURE).

A trace with

sudo dtruss -f sudo -u stefan ./VBoxSVC

made clear that the VirtualBox folder could not be created inside my ~/Library folder due to a lack of permissions. Even creating a folder by me in the directory caused the same problem although I'm the owner.

The permissions show that the ACLs do not allow to write to the ~/Library directory. The @ means that the ACLs override the UNIX permissions:

drwxr-xr-x@ 48 stefan  staff   1632 30 Jan 01:38 Library
 0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown

Now the question is, why a new Lion installation from scratch has set the permissions this way and if someone else has the same problems.

comment:3 Changed 2 years ago by sflemming

I found a way to reset the system to the correct ACLs and OSX automatically corrected my ACL to:

0 drwx------@ 50 stefan staff 1700 21 Apr 12:15 Library 0: group:everyone deny delete

If you have the same problem, you need to start with cmd-R into your recovery system and open the terminal from the menu bar. Enter resetpassword and a new window appears where you can repair all the ACLs of the user directory.

Please do this when you have enough time because it took hours.

Now VirtualBox installs fine.

I'm unsure about the cause of the problem on a freshly installed OSX installation but this seems to be an unusual problem and has nothing to do with vbox so that I think that we can safely close the ticket.

comment:4 Changed 2 years ago by michaln

  • Status changed from new to closed
  • Resolution set to fixed

OK, I'll close this as fixed, just because we can't resolve this as "not our bug". It would be good to know how this situation can happen, but at least we now know how to fix it. Thanks for your help.

Future versions of VirtualBox will give better hints when this happens.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use