VirtualBox

Ticket #10233 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Get the message: Error ID: HostMemoryLow

Reported by: Gangrel Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords: Freeze , No Memory
Cc: Guest type: Windows
Host type: Windows

Description

I'm usually start and use 3 VMs at the same time. But after no change, install or reconfigure I can't use two VMs at same time without special situations.

Using one VM and then start an other one, like I did so many times before, now it start to give me the message: "Failed to load unit 'pgm' (VERR_EM_NO_MEMORY)"

Start only one VM works fine. But for two VMs running at the same time I have to start one, change the VM resolution to a a small one (800x600), close this with saving state machine and do this same steps with an other one. Starting this VMs in that way is the only way to have two running, but increasing the window of VM it locks it with the message: "Error ID: HostMemoryLow

Severity: Non-Fatal Error"

My settings on this VM doesn't give me warnings (like more Video Memory) and all this settings doesn't changed.

I have 8GB on my host machine, and the VMs have 2GB and 3GB. With all of programs running, this scenario doesn't give to me more than 7GB using on host machine. Now, (even reducing the 3GB machine to 2GB) with 5GB on host machine, it says that have low memory.

And I need to work with this VM with resolutions grater than 800x600.

Host Machine: Intel i3 M370 2.4Ghz - 64 Bits RAM: 8GB HD: 128 GB SSD Windows 7 Ultimate 64 Bits

VM 1: 2 Cores - 32 Bits RAM: 2GB Video: 18MB (it always run with that, and is noting requiring more) Windows XP 32 Bits

VM 2: 2 Cores - 64 Bits RAM: 3GB (and changed to 2GB for some tests) Video: 27MB (it always run with that, and is noting requiring more) Windows 7 Ultimate 64 Bits

PS: All OSs and programs are original and licensed.

Attachments

VBox.log Download (83.1 KB) - added by Gangrel 6 years ago.
Log

Change History

Changed 6 years ago by Gangrel

Log

comment:1 Changed 6 years ago by idanciu

try the resolution here: https://www.virtualbox.org/ticket/10219 it worked for me!

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10219. Continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use