VirtualBox

Ticket #10198 (closed defect: worksforme)

Opened 2 years ago

Last modified 17 months ago

VirtualBox service hangs indefinitely

Reported by: gencha Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.1.8 Keywords: hang
Cc: Guest type: other
Host type: Windows

Description

I just made a fresh install of 4.1.8 on Windows 7 x64. When starting VirtualBox, the VBoxSvc process will hang indefinitely (uses 100% CPU time on one core).

This is the stack when it hangs:

USER32.dll!TranslateMessageEx+0x2bf
VBoxDDU.dll!VDCopy+0x27782
VBoxDDU.dll!VDCopy+0x279dc
VBoxDDU.dll!VDCopy+0x27bf6
VBoxDDU.dll!VDCopy+0x27948
VBoxDDU.dll!VDCopy+0x27bf6
VBoxDDU.dll!VDCopy+0x27db2
VBoxDDU.dll!VDCopy+0x28068
VBoxSVC.exe+0x2682df
VBoxSVC.exe+0x2452db
VBoxSVC.exe+0x246962
VBoxSVC.exe+0x268067
VBoxSVC.exe+0xa5af5
VBoxSVC.exe+0x1e48a0
VBoxSVC.exe+0x1e5832
VBoxSVC.exe+0x25ebe7
VBoxSVC.exe+0x260433
ole32.dll!CoRegisterClassObject+0x92d
ole32.dll!CoRegisterClassObject+0x831
RPCRT4.dll!RpcBindingSetAuthInfoW+0xe5
RPCRT4.dll!NdrStubCall2+0x2d2
RPCRT4.dll!I_RpcGetBuffer+0xc7
ole32.dll!CoGetInstanceFromFile+0x4cd3
ole32.dll!CoGetInstanceFromFile+0x511d
ole32.dll!CoGetInstanceFromFile+0x5093
ole32.dll!CoSetState+0x1450
ole32.dll!CoGetInstanceFromFile+0x5926
ole32.dll!CoGetInstanceFromFile+0x567b
ole32.dll!CoGetInstanceFromFile+0x41bd
RPCRT4.dll!NdrServerCall2+0x1d84
RPCRT4.dll!NdrServerCall2+0x1be6
RPCRT4.dll!I_RpcBindingInqTransportType+0x32b
RPCRT4.dll!I_RpcBindingInqTransportType+0x26b
RPCRT4.dll!I_RpcBindingInqTransportType+0x202
RPCRT4.dll!NdrServerCall2+0x1fbd
RPCRT4.dll!RpcBindingCopy+0x5df
RPCRT4.dll!RpcBindingCopy+0x195
ntdll.dll!TpSetTimer+0x39b
ntdll.dll!RtlValidateHeap+0x4af
kernel32.dll!BaseThreadInitThunk+0xd
ntdll.dll!RtlUserThreadStart+0x21

After killing the service process the VirtualBox UI process displays the following error message:

Failed to create the VirtualBox COM object.
The application will now terminate.
Callee RC: CO_E_SERVER_EXEC_FAILURE (0x80080005)

Upon confirming that message, the UI process exits.

I assumed this is a duplicate of this issue: https://www.virtualbox.org/ticket/4975 but I'm not certain anymore.

Attachments

VBoxSVC.log Download (422 bytes) - added by gencha 2 years ago.

Change History

Changed 2 years ago by gencha

comment:1 Changed 2 years ago by frank

Are you sure that this wasn't a long-running operation? From the backtrace it looks like you started a 'VBoxManage clonehd' operation which did not yet finish.

comment:2 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use