VirtualBox

Ticket #10188 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

CentOS 5.7 VBox Guest Additions Failed

Reported by: BTC3 Owned by:
Priority: major Component: installer
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

This is just a note on installing Guest Additions under CentOS 5.7. As originally installed, there is a soft link to a non existent path for build:

/lib/modules/2.6.18-274.el5/build

in CentOS 5.7 running under VirtualBox. This creates a problem when you try to run the VBoxLinuxAdditions.run script, because the Make fails when the kernel directory is setup in:

/usr/src/vboxguest-4.1.8/vboxguest/Makefile.include.header

as:

KERN_DIR := /lib/modules/$(shell uname -r)/build

The soft link should actually be setup as:

/lib/modules/2.6.18-274.el5/build ->

/usr/src/kernels/2.6.18-274.17.1.el5-i686

After the link is fixed, VBoxLinuxAdditions.run runs without any problems.

Regards,

  1. Garrett

Change History

comment:1 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Actually this is a bug in your CentOS setup and not a bug in the VBox installer script, sorry. The 'build' link must be there and it must be correct. Install the correct kernel-devel package and the link will be there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use