VirtualBox

Ticket #10146 (closed defect: duplicate)

Opened 2 years ago

Last modified 13 months ago

No Sound on Linux host

Reported by: Technologov Owned by:
Priority: critical Component: audio
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

Host: Debian Linux 6.0 x64 + VBox 4.1.8

Guest: Windows XP

Sound works in KDE, but not in VBox. I have tried ALSA/OSS/PulseAudio. Nothing works.

-Technologov, 09.01.2012.

Attachments

Windows XP Workstation-2012-01-08-06-09-59.log Download (48.6 KB) - added by Technologov 2 years ago.
VBox.log
Win XP quick-2012-01-09-07-13-59.log Download (46.7 KB) - added by Technologov 2 years ago.
VBox.log 3.2.10_OSE

Change History

Changed 2 years ago by Technologov

VBox.log

comment:1 Changed 2 years ago by Hachiman

Does sound work before update to 4.1.8?

comment:2 Changed 2 years ago by Technologov

hmmm.. Tested Debian's VirtualBox (3.2.10_OSE). Sound works !

Changed 2 years ago by Technologov

VBox.log 3.2.10_OSE

comment:3 follow-up: ↓ 4 Changed 2 years ago by Technologov

Verdict: It is the "multi-distro" installer to blame.

I tested:

Debian's VirtualBox 4.0.10_Debian (from squeeze-backports) - WORKS

Oracle VirtualBox virtualbox-4.0_4.0.10-72479~Debian~squeeze_amd64.deb - WORKS

Oracle VirtualBox VirtualBox-4.0.10-72479-Linux_amd64.run <-- FAILs

-Technologov

comment:4 in reply to: ↑ 3 Changed 2 years ago by Hachiman

Replying to Technologov:

Verdict: It is the "multi-distro" installer to blame.

I tested:

Debian's VirtualBox 4.0.10_Debian (from squeeze-backports) - WORKS

Oracle VirtualBox virtualbox-4.0_4.0.10-72479~Debian~squeeze_amd64.deb - WORKS

Oracle VirtualBox VirtualBox-4.0.10-72479-Linux_amd64.run <-- FAILs

-Technologov

Does  virtualbox-4.1_4.1.8-75467~Debian~squeeze_amd64.deb work in your environment?

comment:5 Changed 2 years ago by Technologov

Yes, it works.

comment:6 Changed 2 years ago by Perryg

It has been my experience that the all distributions (what Alex is call multi-distributions) should only be used if there are no precompiled versions from VirtualBox. With the distros changing location and versions of packages you really can't expect it to work without some effort on the users part.

Perhaps a change in the label from all distributions to generic distributions on the download sites would help users understand this better.

comment:7 Changed 2 years ago by frank

Right Perry, the preferred package would be the distribution-specific package but still, the *all package should really work on all supported distributions. The ALSA problem was already known, it must be some problem with the ALSA stubs.

comment:8 Changed 2 years ago by Technologov

This bug still exists with 4.1.14.

-Technologov

comment:9 Changed 22 months ago by shaunehunter

I have this issue on a Kubuntu 12.04 host using Virtualbox 4.1.18-78361~Ubuntu~presice package from Oracle's repository and it affects all guests.

Any ideas for a work around?

Version 0, edited 22 months ago by shaunehunter (next)

comment:10 Changed 22 months ago by shaunehunter

I have working sound using AC97 with Pulse Audio only. I used Kubuntu a guest to test.

comment:11 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Duplicate of #11615. The other ticket contains more information.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use