VirtualBox

Ticket #10144 (reopened defect)

Opened 2 years ago

Last modified 2 years ago

windows guest additions broken in 4.1.8

Reported by: matteosistisette Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I've upgraded to 4.1.8 (ubuntu 11.10 host, windows 7 guest) from 4.0.12

I have tried to install guest additions on the guest. I checked "Direct 3D support". I got a dialog informing me that support for some feature (Windows Aero or something like that) is experimental, and asking whether I wanted to "install basic 3d support instead" I chose No (I want the experimental full-featured support).

Then I got more or less the following error message (I have to write it by memory): "A corrupt version of Direct 3D has been detected. Installation cannot continue and will be aborted"

Indeed, the installation wizard then hanged forever and never even finished aborting.

So I cannot install the latest guest additions.

Btw, I seem to remember that formerly, in order to install direct 3D support you had to restart windows in safe mode, but you got a warning telling you the steps to follow when trying to intall the guest additions in normal mode, and I haven't seen such a thing now.

Change History

comment:1 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

If you would answer 'yes' then you would have to install the Direct3D support in safe mode. To resolve your problem with the broken files, please have a look at section 12.3.10 of the user manual. The problem is actually in the Guest Additions of the older VirtualBox version and was fixed in 4.1.8. The section in the manual describes how to fix your guest.

comment:2 Changed 2 years ago by matteosistisette

Please for god's sake this needs to be reopened.

I carefully followed the instructions in the manual but there's no way to get rid of the old virtualbox 3D drivers and replace them with window's genuine ones. I keep getting "permission denied", no matter whether I boot in safe mode or not, and even after changing the file owner and permissions (as suggested in many forums). I think the problem is that those files are always in use.

I understand you have fixed the bug for freshly-installed guests on the latest virtual box, but you need to provide a way to fix a guest that was installed on a previous version of virtualbox.

Now I have a broken guest where I can't enable direct 3D support.

comment:3 Changed 2 years ago by matteosistisette

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Oh, I've realized I can reopen it myself :)

comment:4 Changed 2 years ago by matteosistisette

By the way, since the vb upgrade the guest has become so slow that it is completely unusable. I assume it is because of the lack of 3D acceleration support (so the CPU has to do all the work) isn't it?

comment:5 Changed 2 years ago by array

With 4.1.8 didn't see that Problem. My setup is kind of 'fresh' with no old versions. But another problem could be reported maybe. I installed the 3d driver in the old fashion in safe mode but that one turned out to be non WDDM compliant. But it was able to render old direct 2d games. Unfortunately no 3d support for me.

Then i rebootet into the safe mode and removed the drivers. Booted normal and installed the drivers the other way. (Actually the installation process is kind of not so clear about which action causes which result.. could be improved.) Now i have aero support but no 3d or 2d directx game runs. And Aero somewhat crashed into a 'black screen of death' after changing the windows theme. I had to reboot with disabled 3d support (settings of the vm) just to get Windows 7 to show anything more than a black screen.

The 2d video support is nice, but also quite cpu hungry.

I am not using vx-d. Is it ok to install the latest directx even for old games?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use