Ticket #10135 (closed defect: invalid) — at Version 4

Opened 8 years ago

Last modified 8 years ago

Bridged Adapter not working in VirtualBox 4.1.8 on OpenIndiana 151a

Reported by: half12 Owned by:
Component: network/hostif Version: VirtualBox 4.1.8
Keywords: Cc:
Guest type: Linux Host type: Solaris

Description (last modified by ramshankar) (diff)


After upgrading to VirtualBox v4.1.8 on OpenIndiana b151a, I installed an Aerohive HiveManager VM while the VM worked I was unable to ping the management interface or access the web interface.

I downgraded to VirtualBox 4.1.6 r74727 I could ping the management interface and access the web interface.

Change History

comment:1 Changed 8 years ago by ramshankar

OpenIndiana b151a isn't an officially supported host, but if it turns out to be a real bug in the bridged networking code, I'd like to fix it nonetheless. If it means I have to install OpenIndiana + your VMs + your network setup and try to reproduce this issue, chances are high that I won't get time for it.

Could you please provide more detail on the problem?

What is "Aerohive Hive Manager"? How have you configured the VM? What interfaces do you have on the host and how are they setup? What are the addresses you're trying to ping? Are they reachable from the host?

Could you please upload VBox.log for the failing VM session along with output of the following commands (as root):

ifconfig -a
dladm show-link
uname -a
modinfo | grep vbox

Changed 8 years ago by half12

Aerohive HiveManager intial install under VirtualBox 4.1.8, lan not working

Changed 8 years ago by half12

Aerohive HiveManager initial install under VirtualBox v4.1.6, Lan working

Changed 8 years ago by half12

Aerohive HiveManager after upgrading to VirtualBox 4.1.8

comment:2 Changed 8 years ago by half12


I initially installed the Aerohive HiveManager VM (a CentOS based appliance) as via a VMware OVF and VMDK file. The installation worked, however after powering up the Virtual Machine everything was working however I could not access the lan interface. As I had previously had an earlier version running, I downgraded VirtualBox from 4.1.8 to v4.1.6 and ran the Virtual Machine it worked without problem. I have now this evening uninstalled VirtualBox 4.1.6 and re-installed 4.1.8 and it is working but I have not rebooted my computer yet.

As an aside VirtualBox does not seem to be able to install VMware OVA files, but if I tar -xf the ova file and get the ovf and vmdk file it is quite able to import these.

$ ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
	inet netmask ff000000 
nge0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
	inet netmask ffffff00 broadcast
vboxnet0: flags=201000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,CoS> mtu 1500 index 4
	inet netmask ffffff00 broadcast
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
	inet6 ::1/128 

$ dladm show-link
nge0        phys      1500   up       --         --
vboxnet0    phys      1500   up       --         --

$ uname -a
SunOS ts 5.11 oi_151a i86pc i386 i86pc

$ modinfo | grep vbox
174 fffffffff8a64540    d48 291   1  vboxnet (VirtualBox NetAdp 4.1.8r75467)
176 fffffffff8c87000  2e3b0 290   1  vboxdrv (VirtualBox HostDrv 4.1.8r75467)
245 fffffffff8c2b000   7960 292   1  vboxflt (VirtualBox NetDrv 4.1.8r75467)
245 fffffffff8c2b000   7960   -   1  vboxflt (VirtualBox NetMod 4.1.8r75467)
246 fffffffff8c33000   4a18 293   1  vboxusbmon (VirtualBox USBMon 4.1.8r75467)
247 fffffffff8c38000   75f8 294   1  vboxusb (VirtualBox USB 4.1.8r75467)

comment:3 Changed 8 years ago by ramshankar

So it's working now? Anyway, you're using the STREAMS netfilter module, there is absolutely no change in that bridged networking area between 4.1.6 and 4.1.8.

comment:4 Changed 8 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to invalid
  • Description modified (diff)

Closing for now.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use