VirtualBox

Ticket #10124 (closed defect: worksforme)

Opened 2 years ago

Last modified 17 months ago

VirtualBox Crashes when Switching Networking Adaptor's "Attached To"

Reported by: Jamie Jackson Owned by:
Priority: major Component: network
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by Hachiman) (diff)

VBox: 4.1.8r75467
Host: Win7
Guest: Ubuntu 11.10

Steps to reproduce

  • Adaptor 3 starts out in Bridged Mode, on my Host's Wireless NIC.
  • I switch Adaptor 3 to NAT.

The host pops up a dialog box that VirtualBox has closed (or something like that). Clicking OK (or whatever the button says) makes the guest window disappear, and the guest shows as aborted.

I've been trying different things to work around this, including "unplugging" (disconnecting) the adaptor before switching its attachment (as I had done to produce the attached log), but that fails, too.

Switching the attachment doesn't always crash VBox, but it seems to maybe 50% of the time.

Oh, and this is new in 4.1.8. My previous version didn't crash with this (common, for me) use case.

Attachments

ubuntu-2012-01-03-18-34-15.log Download (62.5 KB) - added by Jamie Jackson 2 years ago.
VBox.log
WindowsApplicationEvent.log Download (1.7 KB) - added by Jamie Jackson 2 years ago.
Windows Event Log
ubuntu-2012-01-04-13-17-52.log Download (89.6 KB) - added by Jamie Jackson 2 years ago.
VBox.log: Same thing again (switched from bridged to NAT). You'll see I took a snapshot beforehand, anticipating the crash.
Linux-2012-02-16-18-35-47.log Download (66.8 KB) - added by zlo 2 years ago.
attaching a log from my crash, i changed from bridge to nat.
VBox.log Download (65.1 KB) - added by mizzao 20 months ago.
Log up until the crash when changing from bridged to NAT.

Change History

Changed 2 years ago by Jamie Jackson

VBox.log

Changed 2 years ago by Jamie Jackson

Windows Event Log

Changed 2 years ago by Jamie Jackson

VBox.log: Same thing again (switched from bridged to NAT). You'll see I took a snapshot beforehand, anticipating the crash.

Changed 2 years ago by zlo

attaching a log from my crash, i changed from bridge to nat.

comment:1 in reply to: ↑ description Changed 23 months ago by DavidRa

I can confirm this happens repeatably with other configurations, including a Windows 7 guest on VirtualBox 4.1.16. In this case it happens to be a Windows 8 host, and switching from bridged (wired) to NAT causes the fault. Switching the other way, from NAT to bridged/wired, works just fine. Guest has the 4.1.16 extensions installed.

comment:2 Changed 22 months ago by Hachiman

  • Description modified (diff)

Is it reproducible with 4.1.18?

Changed 20 months ago by mizzao

Log up until the crash when changing from bridged to NAT.

comment:3 follow-up: ↓ 4 Changed 20 months ago by mizzao

This just happened to me as well on 4.1.20 with an Ubuntu guest on a Windows 7 x64 host. Switching from bridged to NAT caused the crash.

Attached is the log up until the crash. Doesn't seem to contain anything too interesting, though.

comment:4 in reply to: ↑ 3 Changed 20 months ago by Hachiman

Replying to mizzao:

This just happened to me as well on 4.1.20 with an Ubuntu guest on a Windows 7 x64 host. Switching from bridged to NAT caused the crash.

Attached is the log up until the crash. Doesn't seem to contain anything too interesting, though.

Could you please collect minidamp?

comment:5 Changed 20 months ago by Lelik

Could you also provide more information about guest running and its networking config please? Unable to reproduce this problem.

comment:6 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use