VirtualBox

Ticket #10121 (reopened defect)

Opened 2 years ago

Last modified 3 months ago

Guru Meditation (HostMemoryLow) when low memory

Reported by: wacher Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords: memory low, resume, guru mediation
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

I've resumed a virtual machine, but memory low. Expected result is a Paused VM state, but the VirtualBox simple crashed with guru mediation. (First occurence was founded in unofficial test build 4.1.7, see comment #9 of ticket #7929

Attachments

VBox.log Download (71.6 KB) - added by wacher 2 years ago.
Guru mediation when memory low
VBox.2.log Download (80.8 KB) - added by sanchox 2 years ago.
VMLog.zip Download (13.7 KB) - added by gwaddell 2 years ago.
Zipped VM Log
VBox.3.log Download (64.5 KB) - added by Plazgoth 2 years ago.
Linux Mint 12 x64_86-2012-02-02-18-02-55.log Download (84.6 KB) - added by markusk 2 years ago.
VBox.4.log Download (94.3 KB) - added by roygbiv 2 years ago.
VBox.5.log Download (73.5 KB) - added by cmkim 2 years ago.
VBox.6.log Download (84.1 KB) - added by cyplo 2 years ago.
VBox.7.log Download (275.3 KB) - added by matthijs 14 months ago.
leading up to GURU_MEDITATION
VBox.png Download (476.2 KB) - added by matthijs 14 months ago.
screenshot at GURU_MEDITATION
VBox_orobardet.log Download (100.2 KB) - added by orobardet 11 months ago.
tastlist.txt Download (6.9 KB) - added by atisho 5 months ago.
tast list

Change History

Changed 2 years ago by wacher

Guru mediation when memory low

comment:1 Changed 2 years ago by wacher

Sorry, I don't know why I wrote 'VERR_MAP_FAILED' in title. (I've checked #7929 previously, maybe this 'typo' came from there via copy+paste...) So, I would like to change title to GURU_MEDITATION

comment:2 Changed 2 years ago by frank

  • Summary changed from VERR_MAP_FAILED when memory low to Guru Meditation (HostMemoryLow) when low memory

Changed 2 years ago by sanchox

comment:3 Changed 2 years ago by sanchox

Same thing on Win 7 x64 as host when try to install CentOS as guest. VM just crashes when something whith memory.

Changed 2 years ago by gwaddell

Zipped VM Log

comment:4 Changed 2 years ago by gwaddell

I'm getting the same behaviour with VirtualBox 4.1.8r75467 running on a Windows 7 64 bit Host with 6 GB RAM, I've three guests set up on the machine, one with Windows 7 and the rest with Windows Server 2003.

If I try and run any (single) guest with over 1 GB RAM, I get the following error at "boot up"

Error ID: HostMemoryLow, Severity: Non-Fatal Error

The host machine then pauses and wont restart and I have to switch it off and take the RAM down to 1GB.

Also, if I'm running a 1GB RAM guest, and start another one to run concurrently, I get the same error on the second machine. Is there some sort of size limit set at 1GB RAM?

Host Details: windows 7 Professional 64 bit Service Pack 1, 6 GB Ram, Intel core i7-2620M CPU @ 2.7GHz Example Guest Details: windows 7 Professional 32bit Service Pack 1, 2048 MB Ram

Task Manager while Guest is running: CPU Usuage 1-3%, RAM 3.02GB used

I've attached a log file

comment:5 follow-up: ↓ 6 Changed 2 years ago by wacher

The problem still exists in 4.1.9r75927. (Yes, I know that this is not an official release... but it is very annoying)

comment:6 in reply to: ↑ 5 Changed 2 years ago by gwaddell

Replying to wacher:

The problem still exists in 4.1.9r75927. (Yes, I know that this is not an official release... but it is very annoying)

Hi, I have a solution, well it worked for me....

I had read other forum posts about ensuring hardware virtualisation was enabled and I checked on my machine and it was. BUT I went back into the BIOS and double checked and although it was enabled, it was only enabled for something called VT-A I changed this setting to one that said VT-A & VT-D supported and now not only can I run over a 1 GB Ram guest, I can run a 2GB ram guest and a 1GB ram guest concurrently too.

comment:7 Changed 2 years ago by Plazgoth

I am seeing similar issue as well.

I have 8GB physical memory with 6.5 GB free when I try to start the VM with base memory set to 3584MB it fails.

Both the Guest and Host OS are Win 7 64Bit.

This VM has been working for the past few months with base memory set to 4096MB. Not sure what changed but I just started seeing this error tonight. Reducing the base memory to 3072MB gets it to boot.

The VirtualBox version I am using is 4.1.8 r75467

And I have checked in BIOS and VT-x is enabled.

Changed 2 years ago by Plazgoth

Changed 2 years ago by markusk

comment:8 Changed 2 years ago by markusk

Same issue with my System.

Host OS is Win 7 Ent 64Bit. Guest OS are Linux Mint 12 and Ubuntu Linux 10.04. Both 64 Bit.

The VM worked without any problems for the last couple of months. The problem appeared 2 days ago.

I was using version 4.1.8 r75467 and tried 4.0.16 yesterday. Unfortunatly i ran into the same problem.

Changed 2 years ago by roygbiv

comment:9 Changed 2 years ago by roygbiv

Same problem. Host OS is Windows 2008 R2 64bit. Worked well 3 months, until last week, when it crashed with 2048MB of RAM, when it's 6GB total in system, and almost 5 are free. Log attached.

VirtualBox's version is 4.1.8 r75467

Version 0, edited 2 years ago by roygbiv (next)

comment:10 Changed 2 years ago by froling

O my.. I thought it was my computer hardware that has been broken. I have run all kind of memory checks and did not find anything wrong with my laptop. The reason that I suspected hardware errors is because of the fact that the screen start to flicker when the memory consumption begin to reach its limit of 8GB. I suspected that is could be Virtual Box release, the problems started when I updated the Oracle VM VirtualBox Extention Pack to version 4.1.8r75467 but I was not sure. It could be some windows update that could caused my flickering screen and virtual instances limitation of memory consumption. I'm still not sure of this, who am I going to blame, Microsoft or Oracle? No offense I like both of them. I deeply depending on them both. I uninstalled VirtualBox and downloaded an older version of VirtualBox, to my surprise it did not solve the problem, so it could be Microsoft that has released a Windows patch that has broken a feature in windows that VirtualBox depend upon. I could also be VirtualBox that don't revert all parts when I downgraded to it's previous version.

I sincerely hope that this is solved swiftly. I which I can contribute, but I lack the skill of programming OS or Viritualization software.

Host: Win7 64bit with 8GB mem, running several different guests (win 2008 r2, win 2008 32bit, win 2003, Ubunut 10.10, ...)

Last edited 2 years ago by froling (previous) (diff)

comment:11 follow-up: ↓ 12 Changed 2 years ago by cmkim

Same problem. Host: Win7 64bit with 6GB mem, running single guest. a lot of available memory. Guest: Ubuntu 10.10

Changed 2 years ago by cmkim

comment:12 in reply to: ↑ 11 Changed 2 years ago by c_lize

Same issue here: Host Windows 7 64bit guest: Centos 5, w2k3... Using the resource monitor on the host, I can see that Virtualbox is unable to get the memory from the standby memory... Hope this help.

comment:13 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Looks like a duplicate of #10219.

comment:14 Changed 2 years ago by wacher

I think this newer ticket therefore that ticket should be duplicate of this :) Anyway I don't use GoogleCrashHandler64 or other similar thing.

This case is simple. 1) If there are not enough memory for VirtualBox then Vbox will be crashed. 2) If I have started my Microsoft Office before Virtualbox then virtualbox fails. If I have started my virtualbox before Office, then everything is OK.

comment:15 Changed 2 years ago by roygbiv

Wacher, thanks for the tip from another ticket!

That's temporary solution for my problem - killing processes "GoogleCrashHandler64" and "GoogleCrashHandler" made my VMs WORK!!! From that point everything works, amount of RAM can be enlarged to my needs at any guest machine.

Google's frustrating with its shadow updater service :(

And more tips: suppose some applications are affected by GoogleCrashHandler too. For exmaple, X-Lite VoIP client won't start, some crashes occur while routine work in Windows.

Last edited 2 years ago by roygbiv (previous) (diff)

comment:16 Changed 2 years ago by qonos68

Solved on a Windows 7 64-bit system with Virtualbox 4.1.8r75467 simply disabling the "Execution Disable Function" in the machine BIOS. No Google Chrome was installed.

comment:17 Changed 2 years ago by wacher

  • Status changed from closed to reopened
  • Resolution duplicate deleted

A new experience: #10278

Changed 2 years ago by cyplo

comment:18 Changed 2 years ago by cyplo

Same problem here, win7 64 host Attaching the log file. Maybe it migth have something to do with with nvidia drivers memory mapping ?

comment:19 Changed 2 years ago by grossetti

Disabling the "Execution Disable Function" in the machine BIOS did not work for me. I have no Google products installed either. As described in my original ticket #10459 I get this when the host Windows OS runs out of RAM. It is a 32bit WinXP host (the physical machine and VM are 64 bit though).

comment:20 Changed 20 months ago by wacher

This annoying "feature" is still present in 4.2 rc3.

The error log said: Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM

But the VM is not paused, just crashed. I don't have special processes neither any google stuff. I started too much VM and other application, I see. I ran out of memory actually, okay, but please, stay in paused mode (as the message promise it), I don't like this guru :(

comment:21 Changed 20 months ago by frank

That's not a feature but a bug. The reason that it's not fixed yet is that the fix is quite difficult.

comment:22 Changed 16 months ago by mhanor

Not to open another ticket (or should I?): VBox should at least warn the user, when starting a VM which has the RAM size set to a too high value (compared to the available host memory), to avoid the same Guru Meditation. Useful when migrating a VM to another host, that has less available RAM than the previous one, or when running the same VM under different OSes, which have different limitations (32 bit vs 64 bit, as an example).

comment:23 Changed 14 months ago by matthijs

This happens with Win7/64 host. Since I upgraded the host memory from 4Gb to 8Gb, and the VM memory from 2000 to 3072 Mb, whenever VM memory use approaches the 3Bb mark, The system runs into the GURU_MEDITATION state, and I have to close it.... The VM is running Ubuntu 11.10.

I hope my log and screenshot help in resolving this bug.

Changed 14 months ago by matthijs

leading up to GURU_MEDITATION

Changed 14 months ago by matthijs

screenshot at GURU_MEDITATION

comment:24 Changed 13 months ago by frank

As we close other tickets as duplicates to this one I also want to add that there are known compatibility issues with  Prio (Process Priority Saver). Removing this tool from the host fixes the issue for some users.

comment:25 Changed 11 months ago by orobardet

Reproduced in the latest version 4.2.12 :

  • Windows 7 60bit as Host
  • Ubuntu 10.04 as Guest

I juste upgrade RAM of the host from 4Gb to 8Gb, and Guest memory from 1.5Gb to 4Gb. Now, one or two time a day, a warning of low host memory occurs (with about only 1.5G out of 4G used for the guest, and 5G out of 8G the host) when I do some simple task in the guest like refresh a page or click a link in firefox, or load a file in eclipse (with eclipse already loaded). The warning box says the VM is only paused and I need to free memory. There is plenty enough memory available (my host only runs an outlook and a firefox), ant the VM is not pause, it's crashed and in GURU_MEDITATION state. I need to restart it (and lost all unsaved data).

Before upgrading the host to 8Gb, I was using v4.2.10, and never had this error. Alought the guest was really slow (lake of RAM).

Attaching a log.

Changed 11 months ago by orobardet

comment:26 Changed 11 months ago by frank

Sorry for asking but do you have some special application installed like the above mentioned Prio application?

comment:27 Changed 5 months ago by atisho

Is there a plan to fix this defect? If yes, when can we expect the fix? I can only allocate 2046GB memory for each vm and can only run one vm at a time. For my use cases, it pretty much makes virtualbox useless for me. I am switching to windows hyper-v which supports dynamic memory.

comment:28 follow-up: ↓ 29 Changed 5 months ago by frank

We can only fix bugs which we can reproduce. A first step in helping debugging would be to answer my last question. Under normal circumstances these memory conditions will not happen. So if you experience this problem it is very likely that some application is installed which changes the behavior of the Windows memory subsystem.

Changed 5 months ago by atisho

tast list

comment:29 in reply to: ↑ 28 Changed 5 months ago by atisho

I attached the file tastlist.txt which shows what processes my system is running. I don't think I am running Prio. Is there any other application you can easily recognize that causes this issue?

comment:30 Changed 3 months ago by tiria

For solving the problem I used CCCleaner to disable the startup of Skype and all Toshiba tools together with Windows7_64 and I reinstalled VirtualBox. I was not able to identify the single program that was responsible of the problem. If you run skype and the various Toshiba tools after you run VirtualBox the problem will not manifest. It seems related to the startup phase only.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use