VirtualBox

Ticket #10108 (closed defect: fixed)

Opened 2 years ago

Last modified 13 months ago

page allocation failure ... vboxNetFltLinuxPacketHandler

Reported by: msurkova Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

It seems that https://www.virtualbox.org/ticket/5260is reproducible on VirtualBox 4.1.6 too. Host is Ubuntu 10.04 64-bit with 24Cpus and 64Gb of RAM running mix of OpenSuse 11.3 and Ubuntu 10.10 guests.

From the log:

1277948.040050] [<ffffffff81469700>] alloc_skb+0x80/0x190 [1277948.040051] [<ffffffff8146a5b6>] skb_copy+0x36/0xa0 [1277948.040059] [<ffffffffa00ac3a8>] vboxNetFltLinuxPacketHandler+0x98/0x5c0 [vboxnetflt] [1277948.040062] [<ffffffff81019e79>] ? read_tsc+0x9/0x20 [1277948.040065] [<ffffffff81473f19>] dev_queue_xmit_nit+0x129/0x190

Wondering if GSO off trick will help.

Attachments

kern.log Download (9.6 KB) - added by Kees-Jan 2 years ago.
Log fragment of the "page allocation failed" error

Change History

comment:1 Changed 2 years ago by msurkova

sadly, GSO off trick did not help too... Now tried to increase vm.min_free_kbytes to 65535 and will see if this will help

Changed 2 years ago by Kees-Jan

Log fragment of the "page allocation failed" error

comment:2 in reply to: ↑ description Changed 2 years ago by Kees-Jan

It also reproduces on VirtualBox 4.0.16. Host is Ubuntu 10.04 64bits running on a Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz. Guest is Ubuntu 10.04 32bit

Attached is a relevant log fragment

comment:3 Changed 2 years ago by mika.fischer

We're having the same problem with a CentOS 6.2 (x86-64) host and some Linux and Windows guests with Virtualbox 4.1.10r76795. The machine has 32GB of RAM and is using the e1000e network driver. Kernel version is 2.6.32-220.7.1.el6.x86_64.

The relevant part of stack trace is always:

[<ffffffff81422a86>] ? skb_copy+0x36/0xa0
[<ffffffffa04883a8>] ? vboxNetFltLinuxPacketHandler+0x98/0x5b0 [vboxnetflt]
[<ffffffff8142c715>] ? dev_hard_start_xmit+0x155/0x3f0
[<ffffffff81449c2a>] ? sch_direct_xmit+0x15a/0x1c0
[<ffffffff81430f78>] ? dev_queue_xmit+0x4b8/0x6b0

The problem can be triggered by heavy usage of the NFS server running on the same host.

comment:4 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.10. Could be a duplicate of #11178.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use