VirtualBox

Ticket #10102 (new defect)

Opened 2 years ago

Last modified 2 months ago

Network connection lost if enable VirtualBox Bridged Networking Driver

Reported by: djf94 Owned by:
Priority: blocker Component: network
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Please help to look at these logs and give me some ideas what else to try as I can no longer install any 4.x version of VirtualBox on my Lenovo 14" Edge with Windows 7 SP1 x64bit (FYI I have not tried 3.x versions)

The problem:
There is no error given during installing but the problem is after installing (which takes a very long time once it gets to 85% of the install bar - I beleive this is where it is installing the virtualbox network drivers) ALL network connections lose their connection.

If I untick the "VirtualBox Bridge Networking Driver" in the network adapters then their connection is restored and okay. But after that of course I cannot access the virtualboxes via a network so this does not help me.

Looking at the VirtualBox Bridged Networking Driver in device manager it shows: "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)." Manually trying to update the driver with the file in the Virtualbox directory gives the same error

Also the VirtualBox Host-Only Ehternet Adapter device has the same status/error.

I have tried everything I can think of for several days:

  • Run as admin
  • Clear out driver store for any Oracle drivers (using pnputil.exe)
  • Delete INFCACHE.1
  • Deleted HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\Config
  • Set MaxNumFilters to 20 (14 Hex)
  • Try to check the driver files signature is okay (using certmgr and signtool but not too sure how to confirm the results I get)
  • Disable avast antivirus (this is disabling the service so it does not run at all and not just the disable shields)
  • Update all windows updates
  • Updated network drivers (LAN:Realtek PCIe GBE and Wifi:Intel Centrino Advanced-N 6200 AGN)

Many thanks and I looked forward to being able to get VirtualBox running (I miss it and need it)

Attachments

VBoxInstallLog.rar Download (29.2 KB) - added by djf94 2 years ago.
setupapi.app.log Download (192.1 KB) - added by djf94 2 years ago.
setupapi.dev.log Download (51.4 KB) - added by djf94 2 years ago.

Change History

Changed 2 years ago by djf94

Changed 2 years ago by djf94

Changed 2 years ago by djf94

comment:1 Changed 2 months ago by wbickford

I'm seeing the same behavior with VirtualBox 4.3.6 using Windows 7 64-bit for both the guest and the host. My network adapter doesn't work until I go into device properties and un-check the "VirtualBox Bridged Networking Driver" check box. I can then re-enable it for the current session.

In my case I'm testing a new Belcarra USBLAN driver, version 2.4.2.2. The driver is unsigned at the moment - could this be related? I'm going to sign the driver to see if it helps.

I don't have the USB ethernet adapter attached to my virtual machine, nor am I sharing the network connection. The mere presence of the bridged driver prevents normal operation.

comment:2 Changed 2 months ago by wbickford

I signed the driver and the problem I described above persists. I'm going to contact Belcarra support about the issue.

comment:3 Changed 2 months ago by wbickford

The problem I'm seeing appears to be a race condition. When I connect a device I must disable the virtualbox bridge in the host's adapter properties. This allows Windows to sense the media connection and obtain an IP address. Then I can re-enable the virtualbox bridge and everything works for that session.

This worked with VirtualBox 4.3.6 and Belcarra's 2.3 series driver so I'm pushing this over to them for analysis.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use