VirtualBox

Ticket #10079 (closed defect: worksforme)

Opened 2 years ago

Last modified 18 months ago

python support is broken in Debian squeeze packages

Reported by: Technologov Owned by:
Priority: major Component: installer
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Host: Debian Linux 6 x64 + VBox 4.1.8

Squeeze package has broken python support:

 http://download.virtualbox.org/virtualbox/4.1.8/virtualbox-4.1_4.1.8-75467~Debian~squeeze_amd64.deb

The multi-distro installer works:

 http://download.virtualbox.org/virtualbox/4.1.8/VirtualBox-4.1.8-75467-Linux_amd64.run

>>> from vboxapi import VirtualBoxManager
>>> mgr = VirtualBoxManager(None, None)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.6/dist-packages/vboxapi/__init__.py", line 513, in __init__
    exec "self.platform = Platform"+style+"(platparams)"
  File "<string>", line 1, in <module>
  File "/usr/local/lib/python2.6/dist-packages/vboxapi/__init__.py", line 349, in __init__
    import xpcom.vboxxpcom
ImportError: No module named xpcom.vboxxpcom

-Technologov, 24.12.2011.

Change History

comment:1 Changed 2 years ago by Technologov

This Bug is related to bug #10110

comment:2 Changed 2 years ago by frank

I cannot confirm this. Just tried the 4.1.8 i386 package on Squeeze as well as the amd64 package on another Squeeze system. Both work well. My testcase is to start the vboxshell.py script.

comment:3 Changed 2 years ago by Technologov

Indeed right. Just installed on a clean machine. Python works.

It seems, that something is broken / polluted on my desktop host.

Feel free to close as INVALID.

-Technologov

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for re-testing.

comment:5 Changed 23 months ago by Technologov

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Tested with 4.1.16.

Well, on the primary desktop machine it still fails.

IMO the setup should be able to over-write python bindings even on old machine. In fact the multi-distro installer does.

Re-opened.

-Technologov

comment:6 Changed 23 months ago by frank

  • Description modified (diff)

Please describe exactly what you tested and what did not work. As I said, we tested Python support and it worked.

comment:7 Changed 18 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use