VirtualBox

Ticket #10046 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

win 8 devel preview guest install failure

Reported by: johnelee Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Running on xp sp3 host, with several working vms. I had exactly this same problem with installing win 7 64 but am reporting as win 8 devel preview fault because the iso can be downloaded by you from MS. It's an odd horrible feature rather than a big fault but it caused me a lot of wasted time.

Having downloaded the iso, I tried to install it. One of the things the new vm wizard asks is about the memory and the 'storage to be reported to the o/s'. The latter was set to 20G and I wrongly/foolishly thought this was too much so changed it to 6-8G. When I then proceeded with the install after a few seconds of 'windows loading files', windows came up with an error message something the effect of 'cannot load 64 bit app' because you don't have 64 bit instructions. Not true!

If you don't mess with the storage setting it installs fine, but I didn't see a warning or any mention of a severe problem if one changed the 'storage to be reported to o/s, so I think this is a fault!

It's a 3G download from MS so easy to try...

Attachments

WIN-8-test-6gb-hdd.png Download (75.6 KB) - added by Perryg 2 years ago.

Change History

comment:1 Changed 2 years ago by johnelee

That's win 8 64 devel preview from ms that fails btw...

comment:2 Changed 2 years ago by frank

Please attach a VBox.log file of your VM session. If the only difference you made was to decrease the disk space of the hard disk then this does not make any sense. The disk size has nothing to do with the 64-bit instructions.

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

No response, closing (and probably obsolete).

comment:4 Changed 2 years ago by johnlee

No not obsolete! No log was created. I agree - just changing the 'storage to be reported to os' should NOT stop vbox installing win 7-64 or whatever - so it doesn't make any sense - but it does! Of course it isn't related to the 64 bit instructions, just something odd about the way vbox sets up the installation environment - but it is a fault! Why not just try it as I suggested. Only a 3g download from MS, and few minutes to run the wizard & modify eg by few eg 5 Gbytes downwards the val in the box. J

comment:5 Changed 2 years ago by johnlee

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:6 Changed 2 years ago by frank

You wrote that you started the VM and started installing the guest. So there actually was a VBox.log file created! Please attach the log file to this ticket. We already tried to reproduce your problem but were not successful. Just clearly describe what you did and attach the VBox.log file, otherwise we cannot help you.

Changed 2 years ago by Perryg

comment:7 Changed 2 years ago by Perryg

I did try to install Windows-8 x86_64 specifying a 6GB dynamic drive but Windows simply failed at disk partitioning saying there was not enough disk space (12324MB).

comment:8 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Perry, thanks for the test but the reporter obviously used the 32-bit guest which requires PAE. As far as I understood him correctly he changed the size of the hard disk and that somehow changed the PAE setting. Actually thinking again, the PAE setting is off for every Windows guest, at least for VBox 4.1.6. Therefore the complete report is bogus.

32-bit Windows 8 requires PAE and VBox 4.1.10 provides a Windows 8 / 32-bit OS type and enabled PAE for that guest. That type was not available with VBox 4.1.6. One can enable the PAE setting later in the VM settings. I think this problem is solved for VBox 4.1.10.

comment:9 follow-up: ↓ 10 Changed 2 years ago by johnlee

NO - I used the 64 bit first win 7 then win 8 - and I changed the 'disk space shown to os' downwards - _exactly_ as it says in my bug report. I know this because that was the whole reason for the install - to test win 7 64 on my laptop. I then tried win8 64 when that didn't work because the iso would be easily accessible to vbox. (btw I initially reported the problem via the 4.1.6 forum).

I don't think trying to make the reporter seem not to know what he's doing or that he can't tell 32 from 64 is a good idea, even if the report doesn't seem to fit with planet vbox! I've been in the sw business even longer than you have. Seems from what you say above there was a vbox fault (fixed in 4.1.10) - that's why even 'funny' faults need to be looked at IMO, not ignored. J

comment:10 in reply to: ↑ 9 Changed 2 years ago by Hachiman

Replying to johnlee:

I don't think trying to make the reporter seem not to know what he's doing or that he can't tell 32 from 64 is a good idea, even if the report doesn't seem to fit with planet vbox! I've been in the sw business even longer than you have.

Saying that you postulate own responsibility to be a good reporter, knowing that there are could be a lot of "small" details which are causing the issue. VBox logs usually contains information about such details and that saves a lot of time on verbal clarification what do you run and what hardware do you use and which details you might miss in initial description. If you don't know where to find such logs please look at this part of user manuals, describing where all required files are located.

comment:11 Changed 2 years ago by frank

In addition to Hachimans comment: I still said that we tried to reproduce your problem and were not successful. And furthermore, VBox 4.1.10 will enable PAE by default for Windows 8 guests, so the problem should be fixed, regardless if it really existed before or not. Again, before VirtualBox 4.1.10, PAE was always disabled in the VM settings for new 32-bit Windows guests.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use