VirtualBox

Ticket #10025 (closed defect: duplicate)

Opened 2 years ago

Last modified 3 months ago

[VIDEO GAME] Elasto Mania is quite unresponsive and has low frame rate

Reported by: twipley Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Host OS: Ubuntu 32 bits (Oneiric; 11.10); Guest OS: Windows XP 32 bits (latest service pack);

Experimental 3D-acceleration drivers have been installed, and then set to "enabled" in the VirtualBox machine video settings. The game is started in a 4:3 resolution, although twice as large in each axis than the original 640x480 resolution.

Upon playing the game at resolutions higher than 640x480 -- even though the latter resolution also suffers from the issue, however to a lesser degree -- the frame rate significantly diminishes, and the game becomes less and less responsive.

The default options are used (see attached "settings" picture). Disabling vertical synchronization seems not to have much effect towards a solving of this issue.

The computer hardware I am on is quite "reasonable" in its power value (the GPU being a little less powerful than the CPU, though), and Elasto Mania is the only game I have tested over here that suffers from such a low-frame-rate problem under VirtualBox virtualization.

I know the drivers are experimental, but I thought it might be appropriate for a bug ticket to be filed against this issue.

Attachments

settings.png Download (29.5 KB) - added by twipley 2 years ago.
VBox.log Download (55.5 KB) - added by twipley 2 years ago.

Change History

Changed 2 years ago by twipley

comment:1 Changed 2 years ago by twipley

[3D Acceleration]

Last edited 3 months ago by twipley (previous) (diff)

comment:2 Changed 2 years ago by twipley

The shareware demo version of this DirectX-5.0 game also exhibits the same issue.

 http://www.elastomania.com/elma.exe

(tested under a default-installation XP guest.)

comment:3 Changed 2 years ago by twipley

Last edited 3 months ago by twipley (previous) (diff)

Changed 2 years ago by twipley

comment:4 Changed 2 years ago by twipley

Last edited 3 months ago by twipley (previous) (diff)

comment:5 Changed 20 months ago by twipley

It seems the issue has mostly been fixed, either through VirtualBox, Ubuntu, or graphics-driver updates.

There is some residual choppiness in the video, but nothing to the extent that I remember having experienced before. I therefore believe this bug ticket can be closed, and let in for archiving.

Last edited 3 months ago by twipley (previous) (diff)

comment:6 Changed 3 months ago by twipley

It has come to my attention that the  http://www.elastomania.com/elma.exe game now exhibits another issue. Now, the choppiness is gone and the frame rate is good, but the new virtualization problem is that the game is running in _slow_ _motion_! I believe this is new in the 4.3-or-so line.

Try it to see it, it's worth it.

comment:7 Changed 3 months ago by twipley

I've just recognized that either the problem is frame choppiness, either it is extreme slowness. Let me explain.

Back then, in Windows-98 days, the game would run fine (natively). Then, it would get choppy when one played it under XP (which soon became the norm). Though, people discovered that running QuickTime in the background removed the (XP) choppiness. Then, ElmaXP.exe was produced (see below for links), which removed the choppiness by "tuning the system timer on game start, then tuning it back to its normal state on game close."

(both links lead to the same file, useable in combination with demo):  http://zworqy.com/elmaguide/files/ElmaXP.zip (elmaxp file inside);  http://kopasite.net/up/0/ElmaXP.exe.txt (remove the .txt extension).

Without ElmaXP.exe under virtualization, there is choppiness (therefore, same behavior as before). However, with ElmaXP.exe under virtualization, the game is slowed down (never-seen-before behavior).

How come? (I am curious.) And, what is to be done about it?

comment:8 Changed 3 months ago by twipley

Another mirror for the "unsmoothness" fix (which is the way to go for native XPs, but currently has problems using it under VirtualBox):  http://nh.gorodok.net/ElmaXP.zip

Note -- I have tried various vboxmanage commands, such as: VBoxManage setextradata "VM name" "VBoxInternal/TM/TSCTiedToExecution" 1 (didn't change anything); VBoxManage setextradata "VM name" "VBoxInternal/TM/WarpDrivePercentage" 200 (which sped up elma.exe, although didn't change much of the slowness of the good [smooth] version, being elmaxp.exe).

comment:9 Changed 3 months ago by twipley

I have integrated all found info and created a new ticket: https://www.virtualbox.org/ticket/12647

(this one can therefore be closed at will.)

comment:10 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use