VirtualBox

Ticket #10021 (closed defect: fixed)

Opened 2 years ago

Last modified 16 months ago

No Standby of windows 7 hosts, when a usb device is conected to guest

Reported by: helmar74 Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

If a usb device is connected to an guest (Windows XP) on an Windows 7 host the host couldn't hibernate. Suspend to disk is not possible and also suspend to RAM works. This happens on Windows 7 32 and also 64 Bit . If the usb device is disconnected to the guest, hibernation works as designed. This issue occurs on virtual box 4.1.6 and also on 4.1.4. In version 4.0.10 this error didn't occur. In the versions between I don't know. Maybe this is an issue of version 4.1.x? Do you know how to fix it?

Change History

comment:1 in reply to: ↑ description Changed 2 years ago by helmar74

Replying to helmar74:

If a usb device is connected to an guest (Windows XP) on an Windows 7 host the host couldn't hibernate. Suspend to disk is not possible and also suspend to RAM doesn't works. This happens on Windows 7 32 and also 64 Bit . If the usb device is disconnected to the guest, hibernation works as designed. This issue occurs on virtual box 4.1.6 and also on 4.1.4. In version 4.0.10 this error didn't occur. In the versions between I don't know. Maybe this is an issue of version 4.1.x? Do you know how to fix it?

comment:2 Changed 18 months ago by DNS

Hi Frank, sorry for opening a dupe ticket. I realized that this one was opened right after I posted mine.

comment:3 Changed 18 months ago by frank

  • Description modified (diff)

No problem, thanks for the report :)

We were able to reproduce the problem on a Windows 7 host but a fix will take some time.

comment:4 Changed 17 months ago by anshul makkar

The problem has been fixed. The fix should be available in next release 4.2.6.

comment:5 Changed 17 months ago by frank

For impatient users,  here is a test build which contains the fix. Feedback welcome.

comment:6 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix included in VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use