VirtualBox

Ticket #10016 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

vbox kernel module compilation fails with kernel 3.2-rc4

Reported by: mlambda Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: mlambda@… Guest type: other
Host type: Linux

Description

How to reproduce: Compile the 3.2-rc4 kernel on Linux Mint 12 as described in  https://wiki.ubuntu.com/KernelTeam/GitKernelBuild


xxx@xx ~ % sudo dpkg -i linux-image-3.2.0-rc4-custom_3.2.0-rc4-custom-10.00.Custom_amd64.deb linux-headers-3.2.0-rc4-custom_3.2.0-rc4-custom-10.00.Custom_amd64.deb Selecting previously deselected package linux-image-3.2.0-rc4-custom. (Reading database ... 204217 files and directories currently installed.) Unpacking linux-image-3.2.0-rc4-custom (from linux-image-3.2.0-rc4-custom_3.2.0-rc4-custom-10.00.Custom_amd64.deb) ... Done. Selecting previously deselected package linux-headers-3.2.0-rc4-custom. Unpacking linux-headers-3.2.0-rc4-custom (from linux-headers-3.2.0-rc4-custom_3.2.0-rc4-custom-10.00.Custom_amd64.deb) ... Setting up linux-image-3.2.0-rc4-custom (3.2.0-rc4-custom-10.00.Custom) ... Running depmod. Examining /etc/kernel/postinst.d. run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-rc4-custom /boot/vmlinuz-3.2.0-rc4-custom Error! Bad return status for module build on kernel: 3.2.0-rc4-custom (x86_64) Consult /var/lib/dkms/virtualbox-guest/4.1.2/build/make.log for more information. Error! Bad return status for module build on kernel: 3.2.0-rc4-custom (x86_64) Consult /var/lib/dkms/virtualbox/4.1.2/build/make.log for more information. run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-rc4-custom /boot/vmlinuz-3.2.0-rc4-custom update-initramfs: Generating /boot/initrd.img-3.2.0-rc4-custom W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169 W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169 Warning: No support for locale: en_US.utf8 run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-rc4-custom /boot/vmlinuz-3.2.0-rc4-custom run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-rc4-custom /boot/vmlinuz-3.2.0-rc4-custom run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-rc4-custom /boot/vmlinuz-3.2.0-rc4-custom Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.0-rc4-custom Found initrd image: /boot/initrd.img-3.2.0-rc4-custom Found linux image: /boot/vmlinuz-3.0.0-14-generic Found initrd image: /boot/initrd.img-3.0.0-14-generic Found linux image: /boot/vmlinuz-3.0.0-12-generic Found initrd image: /boot/initrd.img-3.0.0-12-generic Found memtest86+ image: /memtest86+.bin Found Windows 7 (loader) on /dev/sda1 done Setting up linux-headers-3.2.0-rc4-custom (3.2.0-rc4-custom-10.00.Custom) ... Examining /etc/kernel/header_postinst.d. run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-rc4-custom /boot/vmlinuz-3.2.0-rc4-custom Error! Bad return status for module build on kernel: 3.2.0-rc4-custom (x86_64) Consult /var/lib/dkms/virtualbox-guest/4.1.2/build/make.log for more information. Error! Bad return status for module build on kernel: 3.2.0-rc4-custom (x86_64) Consult /var/lib/dkms/virtualbox/4.1.2/build/make.log for more information. sudo dpkg -i 86.86s user 10.17s system 119% cpu 1:21.25 total xxx@xx ~ % sudo update-initramfs -ck 3.2.0-rc4-custom update-initramfs: Generating /boot/initrd.img-3.2.0-rc4-custom W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169 W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169 Warning: No support for locale: en_US.utf8 xxx@xx ~ % sudo update-grub Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.0-rc4-custom Found initrd image: /boot/initrd.img-3.2.0-rc4-custom Found linux image: /boot/vmlinuz-3.0.0-14-generic Found initrd image: /boot/initrd.img-3.0.0-14-generic Found linux image: /boot/vmlinuz-3.0.0-12-generic Found initrd image: /boot/initrd.img-3.0.0-12-generic Found memtest86+ image: /memtest86+.bin Found Windows 7 (loader) on /dev/sda1 done


Attachments

make.log Download (8.2 KB) - added by mlambda 2 years ago.
config-3.2.0-rc4-custom Download (84.6 KB) - added by mlambda 2 years ago.
kernel configuration

Change History

Changed 2 years ago by mlambda

Changed 2 years ago by mlambda

kernel configuration

comment:1 Changed 2 years ago by mlambda

The compilation fails with the 3.2-rc5 kernel, too!

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9743.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use