<!DOCTYPE html><html><head>
<style type="text/css">body { font-family:'Times New Roman'; font-size:13px}</style>
</head>
<body>Louis King Jr &lt;inlieuoflou@gmail.com&gt; писал(а) в своём письме Wed, 29 May 2013 15:57:46 +0400:<br><br><blockquote style="margin: 0 0 0.80ex; border-left: #0000FF 2px solid; padding-left: 1ex"><div dir="ltr">Thanks for the explanation and I'm glad the blank window isn't just me. I think I figured out how to properly reply... finally.<br></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, May 29, 2013 at 7:49 AM, Frank Mehnert <span dir="ltr">&lt;<a href="mailto:frank.mehnert@oracle.com" target="_blank">frank.mehnert@oracle.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi,<br>
<br>
On Wednesday 29 May 2013 11:58:15 Louis King Jr wrote:<br>
&gt; Any guest. if I try and add a shared folder it brings up the dialog to add<br>
&gt; them and I can select a drive which is what I normally use shared folders<br>
&gt; for. One thing that happens is "Make permanent" is missing from the dialog<br>
&gt; if I try and add a folder to a guest created before 4.2.51. "Make<br>
&gt; Permanent" shows for a new guest. Once I select a drive to add and click<br>
&gt; okay, a new blank dialog window opens which I can't close and everything is<br>
&gt; frozen. I have to force quit VirtualBox. Mac host. OSX 10.8.3<br>
<br>
first, the "Make permanent" box is only shown for running VMs. If the<br>
VM isn't running (you opened the VM settings and selected "Shared Folders"),<br>
the setting will be always permanent.<br>
<br>
But I see the same blank window here. We will look into it.<br>
<br>
Kind regards,<br>
<br>
Frank<br>
<span class="HOEnZb"><font color="#888888">--<br>
Dr.-Ing. Frank Mehnert | Software Development Director, VirtualBox<br>
ORACLE Deutschland B.V. &amp; Co. KG | Werkstr. 24 | 71384 Weinstadt, Germany<br>
<br>
Hauptverwaltung: Riesstr. 25, D-80992 München<br>
Registergericht: Amtsgericht München, HRA 95603<br>
Geschäftsführer: Jürgen Kunz<br>
<br>
Komplementärin: ORACLE Deutschland Verwaltung B.V.<br>
Hertogswetering 163/167, 3543 AS Utrecht, Niederlande<br>
Handelsregister der Handelskammer Midden-Niederlande, Nr. 30143697<br>
Geschäftsführer: Alexander van der Ven, Astrid Kepper, Val Maher<br>
</font></span><br>_______________________________________________<br>
vbox-dev mailing list<br>
<a href="mailto:vbox-dev@virtualbox.org">vbox-dev@virtualbox.org</a><br>
<a href="https://www.virtualbox.org/mailman/listinfo/vbox-dev" target="_blank">https://www.virtualbox.org/mailman/listinfo/vbox-dev</a><br>
<br></blockquote></div><br></div>
</blockquote><div><br></div><div>Hello.<br></div><div>About the "blank modal window".</div><div>Its an old Qt bug under MacOS X host since Qt 4.5 (which had a lot of changes related to MacOS X look&amp;feel according to Apple HIG).</div><div>Its related to window-modality / application-modality handling (which is represented by the Mac sheet / &nbsp;Mac modal window respectively).<br></div><div>I can't explain it fully because I'm not sure why does that happens myself, but we had a workaround for it which was accidentally removed during one of reworks. Now since the actual issue still present I returned workaround in-place again.</div><div>Thanks for spotting this issue!</div><br><div id="M2Signature"><div>-- </div><div><div><strong><em>With Best Regards,</em></strong></div><div><strong><em>[Oracle/VirtualBox] Sergey Dubov<br></em></strong></div><div><strong><em><br></em></strong></div></div></div></body></html>