[vbox-dev] Prebuilt RPM for VB 5.2.6 fails to install for opeSUSE Tumbleweed and Leap 15.0

Larry Finger Larry.Finger at lwfinger.net
Sun Feb 18 18:15:14 UTC 2018


If one tries to install the openSUSE version on Tumbleweed of Leap 15.0, the 
following error occurs:

finger at Larrylap:~> sudo zypper in 
~/Downloads/VirtualBox-5.2-5.2.6_120293_openSUSE132-1.x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libvpx.so.1()(64bit) needed by 
VirtualBox-5.2-5.2.6_120293_openSUSE132-1.x86_64
  Solution 1: do not install VirtualBox-5.2-5.2.6_120293_openSUSE132-1.x86_64
  Solution 2: break VirtualBox-5.2-5.2.6_120293_openSUSE132-1.x86_64 by ignoring 
some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

I checked the dependencies for all of the packages built using our custom .spec, 
and none of them depend on any version of libvpx.so; however, the build requires 
the libvpx-devel package. TW and Leap 15.0 have libvpx4, not libvpx1.

The above rpm does install on Leap 42.3.

Thanks,

Larry



More information about the vbox-dev mailing list