[vbox-dev] New virtualbox vboxvideo mainline kernel broken in Ubuntu

Gianfranco Costamagna locutusofborg at debian.org
Fri Sep 29 10:30:32 UTC 2017

Hello Hans, Sergio,

>I just tried Fedora kernel 4.13.1-303.fc27, which has the vboxvideo driver enabled,
>with gnome 3.24 from Fedora 26 with both X11 and Wayland and both work fine for me,
>not sure what is going on? Is this with gnome-3.26? I can give that a try if you want,
>but that would point to a gnome bug, not a bug in the vboxvideo.

yep gnome-shell 3.26, but I don't see why it should be a gnome-shell bug.

The dkms driver works, as well as the virtualbox one. Just the linux driver fails
>Is there anything special about the setup of the users seeing this ? Have you tried
>to reproduce this yourself?

Install ubuntu artful beta2 and download the old kernel from launchpad is enough to trigger the issue.
the new kernel in artful has that staging driver disabled, so it can't see it

>This is enabled in Fedora kernels or vanilla kernels , do you mean
>since 4.13.1 vbox guestaditionals drives are in main kernel ?

exactly enabling/disabling 3D acceleration seems to be not helping

>Gianfranco, since kernel 3.11 , vboxvideo_drv.so for xorg-X11 should be
>removed from the system and we start use just vboxvideo.ko (kernel

I removed that file looong time ago, when Debian switched to rootless X server
(I grabbed also the xorg patch that is merged in vbox 5.2 I think)

BTW apt-get install virtualbox-guest-dkms grabs the virtualbox guest driver, and loading
that one works, this is why I'm actually blaming the mainline staging driver :)


More information about the vbox-dev mailing list