[vbox-dev] New virtualbox vboxvideo mainline kernel broken in Ubuntu

Hans de Goede hdegoede at redhat.com
Wed Sep 27 16:16:40 UTC 2017


On 27-09-17 08:46, Gianfranco Costamagna wrote:
> Hello, we tried in Ubuntu to use the new shiny vboxvideo mainline kernel driver
> with the new shiny CONFIG_DRM_VBOXVIDEO config key, and we had to quickly disable
> it to use the old working kernel module.
> Reason: it breaks with wayland.
> see:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1718679
> Right now it will be kept disabled until somebody sorts this out, but the question
> for now is:
> did anybody check/test or had to patch wayland to make it work, or
> has been only tested with X11 server?

I just tried Fedora kernel 4.13.1-303.fc27, which has the vboxvideo driver enabled,
with gnome 3.24 from Fedora 26 with both X11 and Wayland and both work fine for me,
not sure what is going on? Is this with gnome-3.26? I can give that a try if you want,
but that would point to a gnome bug, not a bug in the vboxvideo.

Is there anything special about the setup of the users seeing this ? Have you tried
to reproduce this yourself?



More information about the vbox-dev mailing list