[vbox-dev] ubuntu repo error: "changed its 'Codename' value

Klaus Espenlaub klaus.espenlaub at oracle.com
Mon Nov 27 18:34:30 UTC 2017

Hi Stéphane,

On 27.11.2017 18:25, Stéphane Charette wrote:
> If anyone is getting this error when doing "apt-get update":
> > sudo apt-get update
> > ...
> > E: Repository 'http://download.virtualbox.org/virtualbox/debian
> artful InRelease' changed its 'Codename' value from 'zesty' to 'artful'
> > N: This must be accepted explicitly before updates for this
> repository can be applied. See apt-secure(8) manpage for details.

You clearly adopted the artful repository very early, long before the
5.2.2 announcement went out and maybe even before it was mentioned on
the wiki page. We learned the hard way that Debian doesn't like
"symlinked distro version repositories" and fixed it some hours after it
became public. With Fedora and the like package repositories this works
very well.

It's a tad evil that apt-get very harmlessly warns about a new
repository for artful actually containing files for zesty, but errors
out after the repository is fixed.

Sorry about this hiccup. We'll try hard to remember, but I'm quite
certain that eventually it'll happen again.

> Took me a while to figure it out, as the referenced man page isn't
> very helpful.  Tried re-running "apt-key add", but that didn't fix
> it.  Finally found this solution.  Run it once, and seems to be fine now:
> > sudo apt-get update --allow-releaseinfo-change

It has nothing to do with the key, it was the actual repository content
(because we symlinked it to zesty) which had the glitch - it always
shipped the same package (the one for zesty works just fine with
artful), but we didn't expect that level of repository cleverness/sanity


> Stéphane

More information about the vbox-dev mailing list