[vbox-dev] Linux-4.12-rc1 and rc2 not working as vbox guest ?

Hans de Goede hdegoede at redhat.com
Mon May 29 10:23:14 UTC 2017


On 25-05-17 11:57, Hans de Goede wrote:
> Hi,
> On 24-05-17 18:13, Michael Thayer wrote:
>> 24.05.2017 16:02, Michael Thayer wrote:
>>> 24.05.2017 15:16, Hans de Goede wrote:
>>> [...]
>>>> I cannot get a Fedora 26 guest to boot with either distro-provided or
>>>> self-built 4.12-rc# kernels, the distro-provided 4.11 kernel works fine.
>>>> After selecting a 4.12# kernel in the grub menu the vm shows an empty
>>>> text screen with a cursor in the top left corner and then just hangs.
>>>> Anyone know how to fix this ? This is with VirtualBox 5.1.22 on a Fedora
>>>> host.
>>> Hello Hans,
>>> Downloading F26 alpha now to take a look.  Did you try a serial console
>>> redirected to a host file to get early boot messages?
>>> And I am back at work now and hope look at your patches soon!
>> Just tried 4.12-rc1 from Rawhide (is that right?)  It boots fine here, Ubuntu 17.04 host.  Could it be something in your virtual machine configuration or your host?  A log file for the machine might tell us more.
> Ok, so here is what I did:
> 1) Download F26 nightly compose live iso
> 2) Start virtualbox 5.1.20 from rpmfusion pkgs, create new vm, type "Fedora 64 bit"
> 3) Use vm for a while to test vboxvideo stuff
> 4) Manually install a kernel build from Torvald's latest master with the
> intend to start working on putting the vboxvideo code under drivers/staging
> 5) Hmm, does not boot, lets try a Fedora built 4.12-rc# kernel from rawhide
> 6) Hmm still does not boot, remove 5.1.20 pkgs from rpmfusion, install
>     5.1.22 from virtualbox.org
> 7) Still does not boot (and the 4.11 kernel does still boot) time to mail
>     this list.
> I've just tried installing and booting kernel-4.12.0-0.rc1.git0.1.fc27.x86_64 and
> still no luck. I guess I can try re-recreating the vm, might that help ?

So this morning again I've tried to get my vm to boot with a 4.12 kernel,
no luck. One thing I did notice is that the 4.11 kernel which does work
gives this error very early on during boot:

[    0.000000] ------------[ cut here ]------------
[    0.000000] WARNING: CPU: 0 PID: 0 at arch/x86/kernel/fpu/xstate.c:596 fpu__init_system_xstate+0x48f/0x870
[    0.000000] XSAVE consistency problem, dumping leaves

Which I guess is not normal. Could this be a problem with my host ?
My host is a Fedora 26 install, running 4.11.3, I've tried downgrading
the host kernel to 4.10.7 but that does not help.

Maybe something with Fedora 26's gcc version ? :

[hans at shalem ~]$ rpm -q gcc

Causing a miscompile of the host drivers ?



More information about the vbox-dev mailing list