[vbox-dev] Building Virtual Box Failed

Michael Williams mw7301 at hotmail.com
Thu Mar 30 23:11:20 UTC 2017

I installed libqt5x11extras5-dev and the build got further so that worked, thanks!

From: Vilbig, Ric <ric_vilbig at mentor.com>
Sent: Thursday, March 30, 2017 2:53 PM
To: Michael Williams; vbox-dev at virtualbox.org
Subject: RE: Building Virtual Box Failed

On Ubuntu 16 I found it necessary to install the libqt5x11extras5-dev package.  The configure step worked without it, but the build failed similar to yours.  Do you have this one?

//  RicV

From: vbox-dev-bounces at virtualbox.org [mailto:vbox-dev-bounces at virtualbox.org] On Behalf Of Michael Williams
Sent: Thursday, March 30, 2017 11:38
To: vbox-dev at virtualbox.org
Subject: [vbox-dev] Building Virtual Box Failed

When I try to build Virtual Box I get the message "kmk: *** No rule to make target `/usr/lib/x86_64-linux-gnu/libQt5X11Extras.so', needed by `/home/dev/source/VirtualBox-5.1.18/out/linux.amd64/release/obj/VirtualBox/VirtualBox'.  Stop."

qmake -v is version 3.1 and Qt is version 5.8.0

Any ideas how I can fix this?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.virtualbox.org/pipermail/vbox-dev/attachments/20170330/4996dd9d/attachment.html>

More information about the vbox-dev mailing list