[vbox-dev] Enabling 3D acceleration with VBoxOGL and VBoxECL

Larry Finger Larry.Finger at lwfinger.net
Mon Mar 6 16:46:29 UTC 2017

On 03/06/2017 09:10 AM, Michael Thayer wrote:
> Hello Larry,
> Sorry for the delay, I was away.  Have you got any further here, or should I
> take a look?  (I will be away for most of this week too, but will try to find
> time as soon as possible.)

Thanks for getting back to me. I solved my problems - the major one was that the 
.spec file was changing the SONAME setting for VBoxGL.so and VBoxEGL.so to not 
cause interference with libOGL.so and libEGL.so. As soon as I reversed that 
renaming, then 3D acceleration worked. The library interference was solved by 
adding the line "%global __provides_exclude ^libE?GL.so.1.*$" to the .spec. That 
last line was courtesy of Dominique Leuenberger at SUSE. I still have not 
finished parsing that construct. :)

After all the work of solving the problems, I still had to disable 3D 
acceleration in the vboxadd script. It works fine with a Gnome desktop, but 
fails with Plasma 5 (KDE). As far as I have read, VMWare has a fix for that 
problem, but there is nothing in the public domain. I left the setup code in 
vboxadd, and then added code to remove the linkage required to replace libXGL. 
There is an extensive comment telling the Gnome user how to turn 3D on.

Until there is a Plasma fix, my KDE users will have to be content with the 3D 
button having no effect.


More information about the vbox-dev mailing list