[vbox-dev] Failed to load unit "hda" on OSE VirtualBox 5.1.24 (windows)

Mikhail Kovalev mikhail.kovalev at gmail.com
Thu Jul 27 06:21:24 UTC 2017


Hi Andreas,

thnx a lot for a fast response! A patch or something like that would be
great!

Kind regards,
Mikhail

On Wed, Jul 26, 2017 at 9:47 AM Andreas Löffler <andreas.loeffler at oracle.com>
wrote:

> Hi Mikhail,
>
> the error on the custom-built OSE version high likely comes from
> two revision checks we have in our code, specifically in DevHDA.cpp /
> hdaLoadExec():
>
> if (SSMR3HandleRevision(pSSM) >= 116273)
>
> As the OSE version has a different SVN revision than our official
> versions, this code path won't be taken and therefore the loading fails.
>
> I'll see if I somehow can work around this.
>
> Andreas
>
>
>
> Kind regards / Mit freundlichen Grüßen
>
> ******************************************************************
> Andreas Löffler             | VirtualBox Engineering
> Principal Software Engineer | Oracle Virtualization
>
> ORACLE Deutschland B.V. & Co. KG
> Hauptverwaltung: Riesstraße 25, D-80992 München
> Registergericht: Amtsgericht München, HRA 95603
>
> Komplementärin: ORACLE Deutschland Verwaltung B.V.
> Hertogswetering 163/167, 3543 AS Utrecht, Niederlande
> Handelsregister der Handelskammer Midden-Nederland, Nr. 30143697
> Geschäftsführer: Alexander van der Ven, Jan Schultheiss, Val Maher
>
> Green Oracle <http://www.oracle.com/commitment>
> Oracle is committed to developing practices and products that
> help protect the environment
>
>
>
>
> On 26.07.2017 08:21, Mikhail Kovalev wrote:
> > Hi all,
> >
> > we have a custom-built OSE version of VirtualBox 5.1.24 for windows.
> > When "Intel HDA" is selected as an audio adapter and I create an online
> > snapshot, power off the VM, revert the snapshot and then start the VM
> > again I get an error message "Failed to load unit 'hda'
> > (VERR_SMM_LOADED_TOO_LITTLE)" or "Failed to load unit 'hda'
> > (VERR_SSM_STRUCTURE_MAGIC)".
> >
> > With AC97 all works fine. And I cannot reproduce the problem on the
> > official 5.1.24 build. So there must be something in our build
> > environment that makes it fail. However, our build environment didn't
> > change from version VirtualBox 5.1.22 and with 5.1.22 we didn't have any
> > problems.
> >
> > Does anyone have a hint where the problem could be? And whether there
> > were changes in between 5.1.22 and 5.1.24 that could cause the problem?
> >
> > Here is the relevant part of the log with "VERR_SSM_STRUCTURE_MAGIC"
> > failure and the content of the "hda" unit.
> >
> > 000004796 00:00:04.795395 EMT      VMSetError:
> >
> C:\jenkins\workspace\VirtualBox-x86-amd64\devel\5.1.24\src\VBox\VMM\VMMR3\SSM.cpp(8707)
> > int __cdecl ssmR3LoadExecV2(struct VM *,struct SSMHANDLE *);
> > rc=VERR_SSM_STRUCTURE_MAGIC
> > 000004796 00:00:04.795418 EMT      VMSetError: Failed to load unit 'hda'
> > 000004796 00:00:04.795450 main     GUI:
> > UIMachineLogicNormal::sltCheckForRequestedVisualStateType:
> > Requested-state=0, Machine-state=13
> > 000004796 00:00:04.795460 main     GUI: UISession::sltAdditionsChange:
> > GA state change event came, notifying listeners.
> > 000004796 00:00:04.795461 main     GUI:
> > UIMachineLogicNormal::sltCheckForRequestedVisualStateType:
> > Requested-state=0, Machine-state=13
> > 000004796 00:00:04.795478 EMT      SSM: Unit 'hda' contents:
> > 000004796 00:00:04.795479 EMT      0x00000000: 1c 00 00 00 02 01 20
> > 19-00 80 76 84 83 00 00 00  ...... ...v.....
> > 000004796 00:00:04.795480 EMT      0x00000010: 00 01 34 10 00 00 00
> > 00-00 01 00 01 00 00 00 00  ..4.............
> > 000004796 00:00:04.795481 EMT      0x00000020: 00 00 00 00 00 00 00
> > 00-00 00 00 00 00 00 00 00  ................
> > .....
> > 000004797 00:00:04.796248 EMT      0x00004090: 00 ba 00 be 00 be 00
> > c0-00 c1 00 c0 00 c0 00 b8  ................
> > 000004797 00:00:04.796248 EMT      0x000040a0: 00 b7 00 af 00 af 00
> > ac-00 ac 00 a6 00 a6 00 97  ................
> > 000004797 00:00:04.796249 EMT      0x000040b0: 00 96 00 86 00 85 00
> > 75-00 76 00 66 00 66 00 57  .......u.v.f.f.W
> > 000004797 00:00:04.796250 EMT      0x000040c0: 00 56 00 49 00 49 00
> > 40-00 40 00 32 00 33 00 26  .V.I.I. at .@.2.3.&
> > 000004797 00:00:04.796265 EMT      0x000040d0: 00 25 00               -
> >                         .%.
> > ....
> >
> > I would really appreciate any help you can provide.
> >
> > Best regards,
> > Mikhail
> >
> >
> > _______________________________________________
> > vbox-dev mailing list
> > vbox-dev at virtualbox.org
> > https://www.virtualbox.org/mailman/listinfo/vbox-dev
> >
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> https://www.virtualbox.org/mailman/listinfo/vbox-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.virtualbox.org/pipermail/vbox-dev/attachments/20170727/9372308c/attachment.html>


More information about the vbox-dev mailing list