[vbox-dev] audio issues

Perry Halbert phalbert at cox.net
Thu Apr 27 12:16:38 UTC 2017


Good day Frank,


I too was surprised that there was an improvement. I look at the changes 
and didn't really see any audio areas specifically worked on so I 
calculated that the timing or buffers had been changed in some way on 
the host side code.  To tell you the truth it always looked like a 
buffer issue to me. Anyway it had improved for me for several days and 
not anything that I have done, but today it is back to the same old ways 
of the stuttering and audio out of sync with the video plus the whole 
video skips ahead a second so even the video is jumpy.

I will continue to monitor this and let you know what I find, maybe not 
right away this time.

Best regards,
Perry


On 04/27/2017 02:30 AM, Frank Mehnert wrote:
> Hi Perry,
>
> On Freitag, 21. April 2017 11:02:33 CEST Perry Halbert wrote:
>> As of today r66644 from SVN, audio is much improved but not fixed yet.
>> The stutter is improved but now there are popping issues.  The
>> additional logging shows a greatly reduced amount of the stuttering due
>> to stream full but they still happen.
>>
>> Host Linux 64-bit guest Mint-17 64-bit and tried both ac97 and intel hd
>> audio. I sounds like the intel hd audio might be better than the ac97 to
>> my ears but can not provide empirical data to support the assumption.
>>
>> I don't do a lot with Windows these days but it appears that the audio
>> in a Win-7 guest has been acceptable all along if that is of interest to
>> you.
> thank you for testing. Some status update regarding sound in trunk and in the
> 5.1.x branch:
>
> At the moment the code between trunk and 5.1 drifts away a little bit. In
> principle trunk has the more modern audio framework, in particular it moves
> more audio work from the EM threads (the VCPU emulation threads) to separate
> threads. This is good for the timing and therefore good for audio quality.
> Trunk audio didn't change for some weeks (it still needs improvements),
> therefore we are slightly surprised that you experience improvements with
> the latest trunk updates. I'm also not aware of any recent VMM updates which
> would improve timing...
>
> The 5.1.x branch still uses quite old audio code. We don't want to do
> fundamental changes in 5.1.x but we need to fix certain cases. Especially
> we are aware that Windows 10 AU guests don't work well with 5.1.x (including
> 5.1.20). Unfortunately fixing this is more complicated and conflicts with
> our goal to keep the changes in 5.1.x minimal. I can only say that we are
> trying to improve the situation with Windows 10 AU+ guests but we still don't
> have a final solution.
>
> Kind regards,
>
> Frank

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.virtualbox.org/pipermail/vbox-dev/attachments/20170427/24deaa37/attachment.html>


More information about the vbox-dev mailing list