[vbox-dev] Building/using VirtualBox modules on Tails

Austin English austinenglish at gmail.com
Wed Jan 20 01:35:31 UTC 2016


Great, thanks for a detailed reply!

On Tue, Jan 19, 2016 at 7:33 PM, Alexey Eromenko <al4321 at gmail.com> wrote:
> 1. try to compile vbox without security hardening. + show us output
> 2. try to compile vbox with security hardening. + show us output
>
> I need to see at which stage it fails.
>
> How to see kernel module versions ?
> # modinfo vboxdrv
>
>
> On Wed, Jan 20, 2016 at 3:23 AM, Austin English <austinenglish at gmail.com>
> wrote:
>>
>> On Tue, Jan 19, 2016 at 7:17 PM, Alexey Eromenko <al4321 at gmail.com> wrote:
>> > Hard to answer, because I don't know how Tails works.
>>
>> https://tails.boum.org/
>>
>> > Just see what makes VirtualBox tick in standard Linux (by manually
>> > compiling
>> > and installing vbox), and see how Tails is any different from standard
>> > Linux. (at which stage things break apart)
>>
>> I've tried as much as I can think of (checking /etc/init.d, syslog,
>> dmesg, lsmod, etc.).
>>
>> > In general, you need only one primary kernel module:
>> > -vboxdrv
>> > (other modules are optional)
>>
>> Ok.
>>
>> > +one primary service:
>> > -VBoxSVC
>>
>> the vboxsvc and other modules are loaded. /dev/vboxdrv
>> exists, and looking in /lib/modules shows the virtualbox modules are
>> under the running kernel
>>
>> > And they all need to match in version with GUI.
>>
>> Yes, I've got matching versions, but Virtualbox doesn't consider them
>> usable.
>>
>> How does Virtualbox try to load the modules / check the version
>> numbers? Is there some vbox logging I can enable to debug this?
>>
>> I suspect a bad file permission, missing file, or something along
>> those lines, but I need to know what makes vbox fail..
>>
>> > On Wed, Jan 20, 2016 at 3:03 AM, Austin English
>> > <austinenglish at gmail.com>
>> > wrote:
>> >>
>> >> On Wed, Dec 16, 2015 at 1:38 AM, Austin English
>> >> <austinenglish at gmail.com>
>> >> wrote:
>> >> > Hi there,
>> >> >
>> >> > I've tried to use the community support but gotten no useful replies,
>> >> > and this is more of a developer level question anyway..
>> >> >
>> >> > I'm trying to fix this issue in Tails:
>> >> > https://labs.riseup.net/code/issues/5606
>> >> >
>> >> > I've gotten the modules to build and install, and when I boot up the
>> >> > modified Tails, the vboxsvc and other modules are loaded.
>> >> > /dev/vboxdrv
>> >> > exists, and looking in /lib/modules shows the virtualbox modules are
>> >> > under the running kernel. Making a new vm and trying to start it,
>> >> > however, fails, saying that the modules aren't loaded (possible
>> >> > version mismatch). I don't get any extra logging on stdout/stderr to
>> >> > tell me what is missing / what it's looking for.
>> >> >
>> >> > What logs/options could I use to debug what's going on? Is there any
>> >> > documentation I missed for this?
>> >> >
>> >> > Thanks,
>> >> > -Austin
>> >>
>> >> Ping.
>> >>
>> >> --
>> >> -Austin
>> >>
>> >> _______________________________________________
>> >> vbox-dev mailing list
>> >> vbox-dev at virtualbox.org
>> >> https://www.virtualbox.org/mailman/listinfo/vbox-dev
>> >
>> >
>> >
>> >
>> > --
>> > -Alexey Eromenko "Technologov"
>>
>>
>>
>> --
>> -Austin
>
>
>
>
> --
> -Alexey Eromenko "Technologov"



-- 
-Austin



More information about the vbox-dev mailing list