[vbox-dev] Problems with porting a VritualBox frontend from Windows to Linux

Rūdolfs Bundulis rudolfs.bundulis at gmail.com
Mon Mar 23 11:42:28 UTC 2015


thanks for the quick response. Here are both logs:

VBoxHeadless: http://pastebin.com/5yNy2Mke

My frontend: http://pastebin.com/kLHC4eTD

If you can see what is wrong from these logs I'd like to know so I can
avoid troubling the dev list, for my untrained eye they seemed similar.

> I hope you don't tweak too much in your custom code, because
then we can't easily help with figuring out what might be the cause.

Well, the same code worked without issues on Windows, what I did was just
replace CoCreateInstance with the glue code from your example, and change
names of some accessors.

> can't you try with a newer vbox version, such as 4.3.26?

Well, I hope that someone corrects my if I'm wrong, but as far as I
understand, due to hardening I can't run a custom frontend with 4.3.14+
without recompiling from sources with hardening disabled or adding my
binary to the list of trusted frontends, so in that case I can as well
build from source and debug what exactly is going wrong.

Best Regards,
Rudolfs Bundulis

2015-03-23 13:12 GMT+02:00 Gianfranco Costamagna <
costamagnagianfranco at yahoo.it>:

> Hi,
> can't you try with a newer vbox version, such as 4.3.26?
> cheers,
> G.
> Il Lunedì 23 Marzo 2015 11:25, Rūdolfs Bundulis <
> rudolfs.bundulis at gmail.com> ha scritto:
> Hi,
> I'm porting my existing frontend from Windows (COM) to Linux (XPCOM). I
> was able to successfully plug all the XPCOM stuff from the example in the
> source tree. I am able to successfully obtain an instance of the API, find
> the needed machine and power it up. However after I call IConsole PowerUp I
> get an error which I didn't get on Windows in the VBox.log:
> irtualBox VM 4.3.10_Ubuntu r93012 linux.amd64 (Jan 29 2015 03:52:40)
> release log
> 00:00:02.502397 Log opened 2015-03-15T13:13:26.762531000Z
> 00:00:02.502398 Build Type: release
> 00:00:02.502402 OS Product: Linux
> 00:00:02.502402 OS Release: 3.16.0-30-generic
> 00:00:02.502403 OS Version: #40~14.04.1-Ubuntu SMP Thu Jan 15 17:43:14 UTC
> 2015
> 00:00:02.502424 DMI Product Name: Z9PE-D16 Series
> 00:00:02.502430 DMI Product Version: 1.0X
> 00:00:02.502501 Host RAM: 15995MB total, 15603MB available
> 00:00:02.502531 Executable:
> /tmp/DisplayWall/Build/Linux/Debug/DisplayWallServer
> 00:00:02.502532 Process ID: 16081
> 00:00:02.502533 Package type: LINUX_64BITS_GENERIC (OSE)
> 00:00:02.508922 Installed Extension Packs:
> 00:00:02.508931   VNC (Version: 4.3.10 r93012; VRDE Module: VBoxVNC)
> 00:00:02.557003 SUP: Loaded VMMR0.r0 (/usr/lib/virtualbox/VMMR0.r0) at
> 0xffffffffc0fa9020 - ModuleInit at ffffffffc0fc67a0 and ModuleTerm at
> ffffffffc0fc6a40
> 00:00:02.557025 SUP: VMMR0EntryEx located at ffffffffc0fc7e00,
> VMMR0EntryFast at ffffffffc0fc7a20 and VMMR0EntryInt at ffffffffc0fc7a10
> 00:00:02.558343 Guest OS type: 'Windows7_64'
> 00:00:02.560036 fHMForced=true - Lots of RAM
> 00:00:02.560040 fHMForced=true - SMP
> 00:00:02.560042 fHMForced=true - 64-bit guest
> 00:00:02.563830 File system of '/root/VirtualBox VMs/Windows 7
> XPDM/Snapshots' (snapshots) is unknown
> 00:00:02.563836 File system of '/root/VirtualBox VMs/Windows 7
> XPDM/Windows 7 XPDM-disk2.vmdk' is ext4
> 00:00:02.611317 Shared clipboard mode: Off
> 00:00:02.642036 Drag'n'drop mode: Off
> ....
> 00:00:02.964518 VMSetError:
> /build/buildd/virtualbox-4.3.10-dfsg/src/VBox/VMM/VMMR3/VM.cpp(363) int
> 00:00:02.964523 VMSetError: Not supported.
> 00:00:03.026185 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005)
> aIID={8ab7c520-2442-4b66-8d74-4ff1e195d2b6} aComponent={Console} aText={Not
> supported. (VERR_NOT_SUPPORTED)}, preserve=false
> The code base is the same that worked on windows, and the log does not
> actually state what is not supported. I tried to debug the program using
> the symbol package for ubuntu, but I can only get a stack trace, but not
> walk through the code to find an exact line to see what goes wrong. The
> only big difference i see, that in Windows I was not doing any event
> pumping, while i see code that does xpcom event pumping in the examples,
> could that cause this issue? VBoxManage is able to start the same virtual
> machine fine, I did a diff on the logs, and actually till the error line
> everything is the same, no additional errors or info. Any hints on what am
> I missing?
> Best Regards,
> Rudolfs Bundulis
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> https://www.virtualbox.org/mailman/listinfo/vbox-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20150323/6f87bb45/attachment-0001.html 

More information about the vbox-dev mailing list