[vbox-dev] VirtualBox Windows build instructions

Maarten Hoes hoes.maarten at gmail.com
Wed Aug 5 12:07:42 UTC 2015


Also,

On Wed, Aug 5, 2015 at 1:53 PM, Maarten Hoes <hoes.maarten at gmail.com> wrote:

> Hi,
>
> On Wed, Aug 5, 2015 at 1:42 PM, Frank Mehnert <frank.mehnert at oracle.com>
> wrote:
>
>> Hi,
>>
>> On Wednesday 05 August 2015 13:33:12 Maarten Hoes wrote:
>> > Setting
>> > set VBOX_ASSERT=none
>> > before starting Virtualbox.exe gives me this error on startup of
>> previously
>> > created VM's :
>> >
>> > " ...
>> > Failed to open a session for the virtual machine.
>> > Implementation of the USB 2.0 controller not found !
>> > Because the USB 2.0 controller state is part of the saved VM state, the
>> VM
>> > cannot be started. To fix this problem, either install the 'Oracle VM
>> > VirtualBox Extension Pack' or disable USB 2.0 support in the VM settings
>> > (VERR_NOT_FOUND).
>>
>> this error has nothing to do with VBOX_ASSERT=none. The reason is just
>> that your self-compiled package will look for the Extension Pack in
>> out/win.amd64/..../ rather than in C:\Program Files\Oracle\VirtualBox.
>> Therefore better either disable settings required for the Extension Pack
>> or copy the content of the Extension Pack to the correct target. If needed
>> I can tell you the exact paths.
>>
>> Kind regards,
>>
>> Frank
>>
>
> Thanks.
>
>
> Well I copied the 5.0.1 release files from
>
> C:\Program
> Files\Oracle\VirtualBox\ExtensionPacks\Oracle_VM_VirtualBox_Extension_Pack
>
> to the location of the installed debug version :
>
>
> D:\VirtualBox-5.0-amd64-debug\bin\ExtensionPacks\Oracle_VBoxDTrace_Extension_Pack
>
> but I guess thats not correct, as I still get the same error.
>
>
> Anyway, it works for the newly created vm now.
>
>

Disabling USB and the 2nd host only network interface enables the
previously created vm to start up without further errors, but ..
pinging/connecting to an outside host like www.google.com *still* fails for
the previously created vm, even though what appears to be the the same
settings are working for the bridged adapter vm that I created with this
debug release.
?


- Maarten
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20150805/441508b7/attachment.html 


More information about the vbox-dev mailing list