[vbox-dev] Horrible (3D???) performance in F20 guests when it uses Gnome Shell (default)

Sérgio Basto sergio at serjux.com
Sat Sep 13 18:25:55 UTC 2014


On Qua, 2014-05-21 at 09:48 -0500, Perry Halbert wrote:
> I would expect glxinfo | grep render to return chromium if in fact the
> VBox 3D drivers are loaded not Gallium.  Are you certain that you have
> achieved activation of the VBox 3D drivers?

many thanks for the tips , I enabled just 3D and not 2D 
I got chromium and could play tux race ( a 3D game ) 
with VirtualBox-4.3.16_rpmfusion 
thks 

sergio at localhost:~#glxinfo | grep render
libGL error: pci id for fd 4: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa
table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa
table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo
direct rendering: Yes
OpenGL renderer string: Chromium


> 
> On 05/21/2014 09:25 AM, Sérgio Basto wrote:
> 
> > [sergio at efilmsr ~]$ glxinfo | grep render
> > libGL error: failed to authenticate magic 6
> > libGL error: failed to load driver: vboxvideo
> > direct rendering: Yes
> >     GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
> > OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
> >     GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render,
> > 
> > 
> > seems good here, despite swrast load error .
> > 
> > On Qua, 2014-05-21 at 07:14 -0700, quickbooks office wrote: 
> > > I did uninstall 4.3.12 guest additions before trying the rpmfusion's
> > > guest additions.
> > > 
> > > swrast_dri.so ==> software rendering
> > > 
> > > In particular, if the driver is not found in the mentioned path,
> > > OpenGL will try to fall back to the software renderer called
> > > swrast_dri.so. This is an indication that the DRI drivers are not
> > > installed correctly. source: http://dri.freedesktop.org/wiki/glxinfo/
> > > 
> > > 
> > > 
> > > On Wed, May 21, 2014 at 5:58 AM, Sérgio Basto <sergio at serjux.com>
> > > wrote:
> > >         LIBGL_DEBUG=verbose glxinfo
> > >         name of display: :0
> > >         libGL error: failed to authenticate magic 3 
> > >         libGL error: failed to load driver: vboxvideo
> > >         
> > >         libGL: OpenDriver: trying /usr/lib/dri/tls/swrast_dri.so
> > >         libGL: OpenDriver: trying /usr/lib/dri/swrast_dri.so
> > >         libGL: driver does not expose
> > >         __driDriverGetExtensions_swrast(): /usr/lib/dri/swrast_dri.so:
> > >         undefined
> > >         symbol: __driDriverGetExtensions_swrast
> > >         display: :0  screen: 0
> > >         direct rendering: Yes
> > >         
> > >         [   17.068518] [drm] Initialized drm 1.1.0 20060810
> > >         [   17.209723] [drm] Supports vblank timestamp caching Rev 2
> > >         (21.10.2013).
> > >         [   17.209726] [drm] No driver support for vblank timestamp
> > >         query.
> > >         [   17.209745] [drm] Initialized vboxvideo 1.0.0 20090303 for 
> > >         0000:00:02.0 on minor 0
> > >         
> > >         
> > >         
> > >         men , first uninstall your additionals installation , after on
> > >         guest
> > >         system , with some browser
> > >         go to http://rpmfusion.org/Configuration
> > >         click on RPM Fusion free for Fedora 20 and install it , if you
> > >         want sign
> > >         verification , but you may trust on this package for a quick
> > >         install
> > >         see
> > >         https://ask.fedoraproject.org/en/question/37820/confusion-with-rpm-fusions-signing-keys/?answer=38282#post-id-38282
> > >         
> > >         after that :
> > >         yum install VirtualBox-guest kmod-VirtualBox
> > >         restart X or vm
> > >         and it is installed and you don't need worry about upgrade
> > >         kernels
> > >         anymore 
> > >         
> > >         On Qua, 2014-05-21 at 07:33 +0100, Karoline Haus wrote:
> > >         > I have the same problem with VBox 4.3.6 and 4.3.8. Looking
> > >         inside the
> > >         > FC20 guest I can see the CPU being used 100% by the
> > >         gnome-shell. The
> > >         > VBox process on the host of that FC20 VM also runs at 100%.
> > >         When I
> > >         > kill the gnome-shell, CPU utilization returns to normal
> > >         again. Haven't
> > >         > tried to investigate this problem any further yet.
> > >         >
> > >         > quickbooks office <quickbooks.office at gmail.com> schrieb am
> > >         14:25
> > >         > Samstag, 17.Mai 2014:
> > >         >
> > >         >
> > >         >
> > >         > I got this with 4.3.12 Guest Additions also.
> > >         >
> > >         >
> > >         > So I tried your guest additions found in rpmfusion repo.
> > >         Same problem:
> > >         >
> > >         > [user at localhost ~]$ journalctl -b | grep vboxvideo
> > >         > May 17 05:03:57 localhost.localdomain
> > >         systemd-modules-load[302]:
> > >         > Inserted module 'vboxvideo'
> > >         > May 17 05:03:57 localhost.localdomain kernel: [drm]
> > >         Initialized
> > >         > vboxvideo 1.0.0 20090303 for 0000:00:02.0 on minor 0
> > >         > May 17 05:04:12
> > >         localhost.localdomain /usr/bin/dbus-launch[835]: libGL
> > >         > error: failed to load driver: vboxvideo
> > >         > May 17 05:04:16 localhost.localdomain gnome-session[835]:
> > >         libGL error:
> > >         > failed to load driver: vboxvideo
> > >         > May 17 05:04:42 localhost.localdomain gnome-session[1297]:
> > >         libGL
> > >         > error: failed to load driver: vboxvideo
> > >         > [user at localhost ~]$
> > >         >
> > >         > [user at localhost ~]$ glxinfo
> > >         > name of display: :0
> > >         > libGL error: failed to authenticate magic 4
> > >         > libGL error: failed to load driver: vboxvideo
> > >         > display: :0  screen: 0
> > >         >
> > >         >
> > >         >
> > >         >
> > >         > On Thu, May 15, 2014 at 8:30 AM, Sérgio Basto
> > >         <sergio at serjux.com>
> > >         > wrote:
> > >         >         On Qua, 2014-05-14 at 14:57 -0700, quickbooks office
> > >         wrote:
> > >         >         > May 14 13:47:53
> > >         >         localhost.localdomain /usr/bin/dbus-launch[954]:
> > >         >         > gnome-session-is-accelerated: llvmpipe detected.
> > >         >         > May 14 13:47:53
> > >         >         localhost.localdomain /usr/bin/dbus-launch[954]:
> > >         libGL
> > >         >         > error: failed to load driver: vboxvideo
> > >         >         > May 14 13:47:53
> > >         >         localhost.localdomain /usr/bin/dbus-launch[954]:
> > >         libGL
> > >         >         > error: failed to authenticate magic 1
> > >         >         >
> > >         >         >
> > >         >         > Using 4.3.10 guest additions.
> > >         >
> > >         >
> > >         >         selling my fish you could try
> > >         >         rpmfusion repos http://rpmfusion.org/Configuration
> > >         >
> > >         >         and do :
> > >         >
> > >         >         yum install VirtualBox-guest kmod-VirtualBox
> > >         >
> > >         >         before remove all stuff of guest additions.
> > >         >         >
> > >         >         >
> > >         >         > On Tue, Mar 18, 2014 at 4:00 PM, quickbooks office
> > >         >         > <quickbooks.office at gmail.com> wrote:
> > >         >         >         There is horrible (3D???) performance in
> > >         F20 guests
> > >         >         when it
> > >         >         >         uses Gnome
> > >         >         >         Shell (default)
> > >         >         >
> > >         >         >         Is something broken with the Guest
> > >         Additions (i.e.
> > >         >         vboxvideo
> > >         >         >         driver)?
> > >         >         >
> > >         >         >         Please compare a Fedora 20 (or rawhide -
> > >         F21) guest
> > >         >         running
> > >         >         >         Gnome
> > >         >         >         Shell vs. Windows 7.
> > >         >         >
> > >         >         >         In fact even a Windows 8.1 guest is faster
> > >         than a
> > >         >         Fedora
> > >         >         >         guest.
> > >         >         >
> > >         >         >
> > >         >
> > >         >         > _______________________________________________
> > >         >         > vbox-dev mailing list
> > >         >         > vbox-dev at virtualbox.org
> > >         >         >
> > >         https://www.virtualbox.org/mailman/listinfo/vbox-dev
> > >         >
> > >         >         --
> > >         >         Sérgio M. B.
> > >         >
> > >         >
> > >         >         _______________________________________________
> > >         >         vbox-dev mailing list
> > >         >         vbox-dev at virtualbox.org
> > >         >         https://www.virtualbox.org/mailman/listinfo/vbox-dev
> > >         >
> > >         >
> > >         >
> > >         > _______________________________________________
> > >         > vbox-dev mailing list
> > >         > vbox-dev at virtualbox.org
> > >         > https://www.virtualbox.org/mailman/listinfo/vbox-dev
> > >         >
> > >         >
> > >         >
> > >         >
> > >         
> > >         
> > >         --
> > >         Sérgio M. B.
> > >         
> > > 
> > > 
> 
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> https://www.virtualbox.org/mailman/listinfo/vbox-dev

-- 
Sérgio M. B.




More information about the vbox-dev mailing list