[vbox-dev] Windows build status

Rūdolfs Bundulis rudolfs.bundulis at gmail.com
Sat Oct 25 10:53:25 UTC 2014

Hi Klaus,

thanks, running the comregister script from elevated cmd fixed the issue
and now everything seems fine and I can debug the weird access violations I
get in my frontend from VBoxC, thanks a lot.

2014-10-24 13:06 GMT+03:00 Rūdolfs Bundulis <rudolfs.bundulis at gmail.com>:

> Hi Klaus,
> I uninstalled the VirtualBox package that I had before the build so if
> there isn't anything that is not being cleaned up nothing should collide.
> I think I also tried running regsvr32 from a cmd.exe running as
> administrator, but I'm not 100% sure, thanks, that is a good tip and I will
> verify it.
> Rudolfs
> 2014-10-24 12:57 GMT+03:00 Klaus Espenlaub <klaus.espenlaub at oracle.com>:
>> Rudolfs,
>> On 24.10.2014 10:00, Rūdolfs Bundulis wrote:
>> > Hi,
>> >
>> > I eventually managed to build the latest release from sources without
>> > the hardening and using VBOX_QUICK since I don't need the frontends so
>> > this removed some of the dependencies which was nice. The build
>> > finished without any errors, however I'm unable to register the COM
>> > interface, I'm runnging comregister.cmd and also tried to run regsvr32
>> > from command line, the dialog box says that registration was
>> > successful, however CoCreateInstance always fails, and when I dumped
>> > the list of registred classes from the registry I could not find
>> > anything VirtualBox or Oracle related. Does the debug build use some
>> > other UUID or are there any log files or other hints how I could find
>> > what is going wrong?
>> Did you run comregister.cmd as admin? Otherwise it's not able to change
>> the relevant registry entries - and I faintly remember that it's best
>> not to use comregister.cmd when a "proper" VirtualBox package is
>> installed currently (forgot if it just causes trouble with uninstall or
>> if there was some more serious trouble).
>> I'm not aware of generic COM logging (because that's what apparently
>> fails)... you might try if manually starting VBoxSVC works around the
>> error, because if it does it's definitely a registry problem and nothing
>> else.
>> Klaus
>> _______________________________________________
>> vbox-dev mailing list
>> vbox-dev at virtualbox.org
>> https://www.virtualbox.org/mailman/listinfo/vbox-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20141025/843fdd1d/attachment.html 

More information about the vbox-dev mailing list