[vbox-dev] SVN r53052 Win-GAs 4.3.53-96515

Perry Halbert phalbert at cox.net
Sat Oct 18 15:48:34 UTC 2014


Further testing shows an interesting issue. Going to full screen ( 
host-F ) produces an overlay that is not controllable.  Nothing with the 
mouse works.  Going back out of full screen leaves the overlay and also 
a black main guest window behind the overlay.  Only way out is to abort 
the guest.

I would post a screen shot but it exceeds the 100k limit.  Let me know 
if you would like an email sent so you can see what I am talking about.  
Actually if you simply test this on a Linux host & Windows 7 guest ( 
tested with Linux guest and it also fails the same way )  you should see 
it yourself.

Build r53052 with "#define CR_RENDER_FORCE_PRESENT_MAIN_THREAD" 
commented out.

If I go full screen window mode ( click the full screen "box" on the 
upper right part of the menu bar ) it works as it should as well as 
dragging with mouse to increase the screen size.

Perry


On 10/16/2014 08:14 AM, Perry Halbert wrote:
> Good morning Vitali,
>
> Yes that does in fact take care of the issue.
>
> Windows was upset for a bit and dropped aero but a log off and on 
> fixed that.
>
> Let me know if there are any further test you would like for me to make.
>
> Regards,
>
> Perry
>
>
> On 10/16/2014 01:17 AM, Vitali Pelenjow wrote:
>> Perry,
>>
>> I wonder if it is the #define CR_RENDER_FORCE_PRESENT_MAIN_THREAD in
>> src/VBox/HostServices/SharedOpenGL/render/renderspu_glx.c
>>
>> Could you comment out the define and see if it makes any difference?
>>
>> Thanks,
>> Vitali.
>>
>> Perry Halbert wrote:
>>>
>>> Note: I think I have isolated the reported issue to the updates on 
>>> Aug 4th 2014.
>>>
>>>
>>>
>>>
>>>
>>> On 10/15/2014 05:39 PM, quickbooks office wrote:
>>>> I think watching videos in Linux guests is also broken. Can you try 
>>>> watching a video with totem and see? Then pause the video and try 
>>>> doing something else in the guest.
>>>>
>>>> On Tue, Oct 14, 2014 at 3:38 PM, Perry Halbert <phalbert at cox.net 
>>>> <mailto:phalbert at cox.net>> wrote:
>>>>
>>>>     I'm not sure how close you are to releasing 4.4.0 but I thought I
>>>>     should mention that the Windows video is not working properly.
>>>>
>>>>     Graphics flicker and show the desktop like a clear piece of glass.
>>>>
>>>>     Host is Debian based ( mine own build but resembles mint-17 ) and
>>>>     guest is Windows-7 x64 ( log file attached ) with updates as of
>>>>     today.
>>>>
>>>>     It has something to do with 3D (wddm) but I think it is actually
>>>>     host side as I can't seem to get it to work properly with older
>>>>     GAs that I have.
>>>>
>>>>     Not an issue for me because I only use Windows to test with but
>>>>     if you need something to help let me know.
>>>>
>>>>     Perry
>>>>
>>>>     _______________________________________________
>>>>     vbox-dev mailing list
>>>> vbox-dev at virtualbox.org <mailto:vbox-dev at virtualbox.org>
>>>> https://www.virtualbox.org/mailman/listinfo/vbox-dev
>>>>
>>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> vbox-dev mailing list
>>> vbox-dev at virtualbox.org
>>> https://www.virtualbox.org/mailman/listinfo/vbox-dev
>>
>>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20141018/7576fb1f/attachment.html 


More information about the vbox-dev mailing list