[vbox-dev] Sketch of how to build on OSX 10.9?

Vadim Galitsyn vadim.galitsyn at oracle.com
Wed Jun 18 14:05:54 UTC 2014


Hi Jon,

> Would I be better off editing the source to allow it to build against
> the 10.9 SDKs or, alternatively, trying to find copies of the earlier
> SDKs and building against those?

Please do not use 10.9 SDK, but use 10.6 one instead which comes with Xcode 3.2.0.
I understand that it is currently not possible to install Xcode 3.2.0 on Mavericks host,
but if you have it previously installed into some other location, you may “svn up” your local copy of OSE
repository and configure it in the following way (--with-xcode-dir option was introduced just today):

./configure --disable-hardening --with-xcode-dir=<path to Xcode 3.2.0> --with-qt-dir=/opt/local/Library

Hope this helps,
Vadim




More information about the vbox-dev mailing list