[vbox-dev] v box registering COM objects

Lucian Apetre lucian_apetre at yahoo.com
Sun Nov 10 22:21:58 UTC 2013

I build vbox sources on a x86 machine, under win 7. On my machine, the binaries build from sources from: VirtualBox-4.3.0\out\win.x86\release\bin\VirtualBox.exe work fine, opens a virtual box. 
But when I'm moving the bin folder to another pc(a clean win 8 x86 machine) i get this error:

"Failed to create VirtualBox COM object, the application will now terminate"
Details: "Callee RC: REGDB_E_CLASSNORTEG(0x80040154)"
And the VirtualBox.exe does not open.
I tried:
1. moved all qt related dlls and curl related dlls to the new clean PC(win 8 x86)(dlls requested when tried to open virualbox.exe)
2. registered dlls with: comregister.cmd and loadall.cmd
still does not work

Does anybody have an idea?
Thank you
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20131110/3d0cbef8/attachment.html 

More information about the vbox-dev mailing list