[vbox-dev] OpenGL/3D on Mac Hosts... Screenshots

Sergey Dubov Sergey.Dubov at oracle.com
Fri May 31 09:58:33 GMT 2013

Louis King Jr <inlieuoflou at gmail.com> писал(а) в своём письме Fri, 31 May  
2013 01:00:17 +0400:

> the build is VirtualBox-4.2.51-86105
> On Thu, May 30, 2013 at 4:56 PM, Louis King Jr <inlieuoflou at gmail.com>  
> wrote:
>> the error in the Ternimal....
>> louiss-imac:~ Mine$ VirtualBox -startvm "LMDE Cinnamon" --rmode image
>> VirtualBox: error: Code NS_ERROR_NOT_IMPLEMENTED (0x80004001) - Not  
>> implemented (extended info not available)
>> VirtualBox: error: Context:  
>> 266 of file >>crservice.cpp
>> On Thu, May 30, 2013 at 4:48 PM, Louis King Jr <inlieuoflou at gmail.com>  
>> wrote:
>>> when I use 'VirtualBox -startvm <guest's name> --rmode image' I get a  
>>> message about starting in 16 bit color mode although it does start  
>>> >>>in 32 bit color. The screenshot is still black. That's when I tried  
>>> it with LMDE - Cinnamon.
>>> On Thu, May 30, 2013 at 3:30 PM, Sergey Dubov  
>>> <Sergey.Dubov at oracle.com> wrote:
>>>> Louis King Jr <inlieuoflou at gmail.com> писал(а) в своём письме Thu, 30  
>>>> May 2013 22:00:53 +0400:
>>>>> This has been a long standing problem with VirtualBox running on Mac  
>>>>> hosts. For whatever reason screenshots on Linux guests >>>>>running  
>>>>> Compiz or Unity or Gnome3 or Cinnamon can not take screenshots. All  
>>>>> one gets is an empty black screen. I've been told >>>>>this is not  
>>>>> an issue for the Windows or Linux versions of VB. As of today's  
>>>>> 4.2.51 version it's still an issue. If it is one of the things  
>>>>> >>>>>being worked on currently of course ignore this message.
>>>>> I would mention the current version of Debian 7 with Gnome 3 does  
>>>>> actually work as far as screenshots go and I have no idea why.
>>>> Hi.
>>>> Is it the case with QImage frame-buffer too?
>>>> I mean by default MacOS X host VM uses Quartz2D frame-buffer but  
>>>> there is an experimental QImage frame-buffer support which >>>>can be  
>>>> used by trunk VM through '--rmode image' passed as additional  
>>>> argument to 'VirtualBox -startvm <vm name>' like:
>>>> VirtualBox -startvm Ubuntu --rmode image
>>>> --With Best Regards,
>>>> [Oracle/VirtualBox] Sergey Dubov
>>>>>>>> _______________________________________________
>>>> vbox-dev mailing list
>>>> vbox-dev at virtualbox.org
>>>> https://www.virtualbox.org/mailman/listinfo/vbox-dev


Ok, it seems the screen-shot issue is deeper than the used frame-buffer  
Is it 3D related thing? I mean is the screenshot correct when you are  
getting it with 3D turned off for the same VM?

About error warnings in terminal, you can ignore these warnings for now.
They are related to new functionality which is not yet implemented from  
the GUI side.

With Best Regards,
[Oracle/VirtualBox] Sergey Dubov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.virtualbox.org/pipermail/vbox-dev/attachments/20130531/c8b6524e/attachment.html>

More information about the vbox-dev mailing list