[vbox-dev] Assign physical disks to VirtualBox VM

Klaus Espenlaub klaus.espenlaub at oracle.com
Mon Mar 18 08:25:58 PDT 2013

On 17.03.2013 16:46, tech mailinglists wrote:
> Hello all,
> I'm trying to assign a few physical disks to a Ubuntu VM in VirtualBox 
> 4.2.10 (newest) on a Windows 7 host. I read about it and saw that it's 
> managed like in VMWare which I use also. The VM earlier was a VMWare 
> VM so I converted the main disk from vmdk to vdi. This disk I can 
> assign without problems.
> I already used the physical disks in VMWare so I simply tried to use 
> the existing VMDK descriptor/pointer files. This fails in VirtualBox 
> as follows:
> Errorcode:
> VBOX_E_IPRT_ERROR (0x80BB0005)
> Component:
> Medium
> Interface:
> IMedium {29989373-b111-4654-8493-2e1176cba890}
> Callee:
> IVirtualBox {3b2f08eb-b810-4715-bee0-bb06b9880ad2}
> Callee RC:
sounds like the access rights are wrong... but that's just a wild guess. 
There should be more information in the error message text, apparently 
there isn't.
> So I tried to create the files new with VBoxManage and this fails with 
> a COM server error as follows:
> C:\Windows\system32>"C:\Program 
> Files\Oracle\VirtualBox\VBoxManage.exe" internal
> commands createrawvmdk -filename "C:\Users\Laukamp\VirtualBox 
> VMs\Deluge"\deluge
> -PHD1.vmdk -rawdisk \\.\PhysicalDrive1
> VBoxManage.exe: error: Failed to create the VirtualBox object!
> VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - 
> Server execu
> tion failed (extended info not available)
> VBoxManage.exe: error: Most likely, the VirtualBox COM server is not 
> running or
> failed to start.
That usually means that VirtualBox isn't installed correctly. Does the 
GUI start from this command line (VirtualBox.exe)?
> The CMD is started with administrative privileges. The VBoxSVC.exe 
> also is running and I also tried to restart it on CMD to see errors. 
> No errors appeared it started without problems.
Very strange - I guess this is a COM API problem with the two 
"identities" of a single user with and without admin privileges. Windows 
is very annoying with the privileges needed for raw disk access, it's 
really not much fun.
> I also tried to reinstall and tried again but this also gave me no 
> result. I don't know whether this could be a bug so I post this to the 
> users and devel list.
Try running *everything* from an admin command line prompt, without any 
API use by the non-admin user (i.e. don't start the GUI normally).


> Would be great when someone could help me I don't know how I could 
> solve this problem.
> Best Regards
> P.S. Sorry for my bad english.
seen orders of magnitude worse, don't worry :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20130318/65db5165/attachment.html 

More information about the vbox-dev mailing list