[vbox-dev] Build VirtualBox OSE in Windows 7

Hank Chiang hankchiang717 at gmail.com
Thu Jul 18 23:58:46 PDT 2013

Hi all,

I followed the instructions (
http://www.cnblogs.com/cxun/archive/2013/03/12/2956175.html) to
build VirtualBox 4.2.16 for Win32 in Windows 7 64bit environment. However,
I got the error messages when starting the VM and settings. I tried *
comregister.cmd* and *loadall.cmd* many times and it still doesn't work.
Please refer to the steps below and help me. Thanks.

1. Install VS2010 with SP1
2. Install WDDK v7.1
3. Install MinGW v20120426 (from
  3.1 Download GCC 3.3.3 from
  3.2 Unpack and copy all items to the path of MinGW (C:\MinGW)
4. Install QT4.8.5 (from
5. Download SDL v1.2.15 from
6. Download zlib v1.2.8 from http://zlib.net/zlib128-dll.zip
7. Download cURL devel version w/o SSL support (from
8. Download openssl 0.9.8y source code from
  8.1 Download and install ActivePerl to build openssl
  8.2 Open Visual Studio Command Prompt (2010) and enter the root directory
of source code
  8.3 Execute *perl Configure VC-WIN32*
  8.4 Execute *ms\do_ms*
  8.5 Execute* nmake -f ms\ntdll.mak*
  8.6 Rename the folders (include to old_include and inc32 to include)
  8.7 Create a lib folder and copy all .lib file in out32dll folder to it.
  8.8 Create a bin folder and copy all .exe and .dll file in out32dll
folder to it.
9. Install Python 2.7.3 (from

*Building VirtualBox:*
1. Open Visual Studio Command Prompt (2010) -> execute* vcvarsall.bat
x86*-> close
2. Open Visual Studio Command Prompt (2010) with Administrator
3. Change to the kbuild directory in VirtualBox 4.2.16 -> execute *envwin
4. Change to the root directoy -> execute *cscript configure.vbs
--with-MinGW32=<path> --with-libSDL=<path> --with-openssl=<path>
--with-libcurl=<path> --with-Qt4=<path>*
5. execute env.bat
6. execute kmk

*Running VirtualBox:*
1. Change to .\out\win.x86\release\bin
2. Execute *comregister.cmd*
3. Execute *loadall.cmd*
4. Execute *VirtaulBox.exe*
*Error Messages:*
1. When pressing the Start button, I got the message "Cannot access the
kernel driver! Make sure the kernel module has been loaded successfully",
and the next message is "Failed to open a session for the virtual machine"
and the Result Code is E_FAIL (0x80004005).
2. When pressing the Settings button, I got the message "Failed to access
the USB subsystem. Could not load the Host USB Proxy Service
(VERR_FILE_NOT_FOUND). The service might not be installed on the host
computer." and the Result Code is E_FAIL (0x00004005)

1. Can I build VirtualBox ose x86 and x64 in Windows 7/8 64bit environment?
if so, what's wrong in my building step? Is there any document or SOP can
be referenced for building x64 version.
2. There is a parameter called build_target in the env.sh file. Is it
possible that build VirtualBox ose for Windows Host in Linux environment
such as Ubuntu v13.04? If possible, what document or SOP can be referenced?

*Best Regards*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20130719/6c851093/attachment.html 

More information about the vbox-dev mailing list