[vbox-dev] Turning on Virtual Disk (VD group) debug logs on VBox

Quaizar Vohra quaizar.vohra at gmail.com
Thu Jul 11 08:51:13 PDT 2013


Vasily,

Thanks!

I tried your suggestion with a release build and I did not see the logs. I
guess I need a debug build as others have suggested.

Thanks,
Quaizar


On Thu, Jul 11, 2013 at 3:02 AM, Vasily Levchenko <
vasily.levchenko at oracle.com> wrote:

> Hello, Quaizar,
> Do the string
> VBOX_LOG="+main.e.l.f+vd.e.l.f+vd_vdmk.e.l.f+vd.e.l.f"
> trick for you?
>
> On Jul 11, 2013, at 7:39 AM, Quaizar Vohra <quaizar.vohra at gmail.com>
> wrote:
>
> Haven't received any response. Would greatly appreciate any help or hints
> on this.
>
> Thanks,
> Quaizar
>
>
> On Sat, Jul 6, 2013 at 9:20 AM, Quaizar Vohra <quaizar.vohra at gmail.com>wrote:
>
>> I am trying to turn on logging for operations in VD.cpp & VMDK.cpp. I
>> have tried several options with no success.
>>
>> I am on OS X host running Mountain Lion.
>>
>> I have tried turning on the logs by setting the env variables and
>> starting VirtualBox client manually from the same shell (which starts
>> VBoxSvc as well) followed by VirtualBoxVM also from the same shell. Here is
>> what I have tried.
>>
>> qvs-MacBook-Pro:Logs qv$ env | grep VB
>> VBOX_LOG_FLAGS=time tid thread
>> VBOX_LOG=+main.e.l.f+defualt.e.l.f+VD.e.l.f+VD_VMDK.e.l.f
>> qvs-MacBook-Pro:Logs qv$ VirtualBox &
>> [1] 3175
>> qvs-MacBook-Pro:Logs qv$
>> /Applications/VirtualBox.app/Contents/MacOS/../Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM
>> --comment ubuntu-gnome-13.04 --startvm 0daa22b1-4869-4173-bc36-64ee3a558841
>> --no-startvm-errormsgbox &
>> [2] 3180
>>
>>
>> I have run gdb on VirtualBoxVM, attached to the running process and tried
>> calling RTLogGroupSettings(0,
>> "+main.e.l.f+defualt.e.l.f+VD.e.l.f+VD_VMDK.e.l.f");
>>
>> I have tried putting the env variables in my .bash_profile and then
>> starting VirtualBox client from the Launchpad and the VM from VirtualBox
>> still to no avail.
>>
>> Do I need a debug image to turn on this logging? Or is this is a OSX
>> issue?
>>
>> I have also spent some time browsing thru the vbox-log.cpp & log.cpp but
>> haven't got any clues.
>>
>> Would greatly appreciate any help with this.
>>
>> Thanks,
>> Quaizar
>>
>>
>>
>>
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> https://www.virtualbox.org/mailman/listinfo/vbox-dev
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20130711/80d1d604/attachment-0001.html 


More information about the vbox-dev mailing list