[vbox-dev] Vbox kernel driver permission problem

Ramshankar ramshankar.venkataraman at oracle.com
Mon Oct 1 02:14:07 PDT 2012

You are missing the most crucial bit of information. Which host OS are 
you using?

Since you mentioned 777 I assume you're on linux/solaris. Where did you 
try the "777" on?

Did you build it with "VBOX_WITHOUT_HARDENING=1"?


On 10/ 1/12 09:04 AM, Jaikumar G wrote:
> Folks,
>     i have built the vbox build myself and have written a test frontend
> to get familiar with the VBox SDK APIs. I built the kernel driver,
> installed it, gave read and write access. I have given the setuid
> permission to the frontend.
> I still hit this error when launching the frontend. As mentioned above,
> the setuid bit is set, the vbox driver was built and installed and has
> the permissions.
> VirtualBox kernel driver not accessible, permission problem. Re-install
> VirtualBox. If you are building it yourself, you should make sure it
> installed correctly and that the setuid bit is set on the executables
> I even tried 777 on the vbox driver and still no dice.
> Any pointers on how to debug or what is missing ?
> Thanks
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> https://www.virtualbox.org/mailman/listinfo/vbox-dev

More information about the vbox-dev mailing list