[vbox-dev] Problem with running VMs after upgrade from 4.2.2 to 4.2.4

Roy Liu roy at eschatonlabs.com
Mon Nov 26 23:34:29 PST 2012


Sorry for reposting this, but I didn't get a response the last time around.
The VirtualBox Mac Port is failing to start. The ticket can be found here.


FYI, version 4.2.2 worked fine. It would be nice to know what changed in
4.2.4 so as to cause the problem. I didn't change anything significant on
the MacPorts end.


On Mon, Nov 5, 2012 at 3:55 AM, Roy Liu <roy at eschatonlabs.com> wrote:

> Hi,
> I am the maintainer of the VirtualBox Mac Port found here.
> https://trac.macports.org/browser/trunk/dports/emulators/virtualbox/Portfile
> When upgrading from 4.2.2 to 4.2.4, everything built fine, but now my VMs
> fail to start and give the following error.
> """
> Failed to open a session for the virtual machine Windows Server 2008 R2.
> Failed to load VMMR0.r0 (VERR_GENERAL_FAILURE).
> Result Code: NS_ERROR_FAILURE (0x80004005)
> Component: Console
> Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}
> """
> Any ideas on what might have changed to cause the error? I recall that a
> while back I tried compiling VirtualBox with Apple's LLVM toolchain and
> that was a bust. I subsequently fell back on Apple's GCC 4.2 compiler, and
> everything worked fine, until now.
> Any insights you could provide would of great help.
> -Roy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20121127/143248d9/attachment-0002.html 

More information about the vbox-dev mailing list