[vbox-dev] Guests abort when resizing

Klaus Espenlaub klaus.espenlaub at oracle.com
Wed Jul 25 05:00:02 PDT 2012


On 24.07.2012 03:12, Perry Halbert wrote:
> Update. I turned off the remote display and this solved the issue.
> I use VNC and build the extension pack which has been working really well.
> So is there a way to get this back to operational status or do I need to
> switch back to VRDP?

My suspicion is that the VM process crashes... can you enable core dumps 
to see if this hypothesis is right, or run the VM process directly in 
gdb? You build everything yourself, so it shouldn't be a problem to have 
the debug info available. Could be that your libvncserver is newer and 
has a slightly incompatible API somewhere.

I've tried a similar setup (VBox trunk, matching GA, VNC enabled, VT-x 
disabled), but I couldn't get any crashes. Used a different guest OS and 
a different linux distro on the host, but this shouldn't really have a 
significant influence. Tried with and without a VNC viewer connected.

I guess that you run the VM in the GUI, because I wasn't able to find a 
VNC viewer which would trigger resizes when its window is resized.

Any obvious patterns for the resize resolution (we removed a "multiple 
of 4" restriction for the horizontal resolution recently) which causes 
crashes? Does it ever survive a resize?

Klaus

>
>
> On 07/23/2012 06:27 PM, Perry Halbert wrote:
>> Strange issue this time.
>>
>> Latest batch of builds, not sure exactly when, but within the last
>> week. When resizing the guest (mouse click drag) it aborts. Nothing in
>> the guests log file (no shut down, resize information, or reason it
>> just stops recording) or syslog of the guest. Just like you pulled the
>> plug. Only indication is the main manager shows aborted.
>>
>> Host Ubuntu 12.04 x86_64 (no VT-x)
>> Guest Ubuntu 12.04 X86_32 with PAE
>>
>> Everything else works good, including all new features, well except it
>> is really slow and has been for some time, but usable to test with.
>>
>> I increased the vRAM to 64MB from 12MB but that does not seem to be
>> the issue.
>> I removed Version matching GAs and installed 4.1.18, but no change so
>> I don't think it is the GAs.
>> Turned off 3D so that is not the issue.
>>
>> Note: I do not see this on a matching Ubuntu host with VT-x.
>>
>> Didn't I say strange?
>>
>>
>>
>> _______________________________________________
>> vbox-dev mailing list
>> vbox-dev at virtualbox.org
>> https://www.virtualbox.org/mailman/listinfo/vbox-dev
>
>
>
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> https://www.virtualbox.org/mailman/listinfo/vbox-dev


-- 
Oracle <http://www.oracle.com>
Dr. Klaus Espenlaub | Snr. Manager Software Development Desktop
Virtualization
Phone: +49 7151 60405 205 <tel:+49715160405205>
Oracle VM VirtualBox

ORACLE Deutschland B.V. & Co. KG | Werkstr. 24 | 71384 Weinstadt

ORACLE Deutschland B.V. & Co. KG
Hauptverwaltung: Riesstr. 25, D-80992 München
Registergericht: Amtsgericht München, HRA 95603
Geschäftsführer: Jürgen Kunz

Komplementärin: ORACLE Deutschland Verwaltung B.V.
Hertogswetering 163/167, 3543 AS Utrecht, Niederlande
Handelsregister der Handelskammer Midden-Niederlande, Nr. 30143697
Geschäftsführer: Alexander van der Ven, Astrid Kepper, Val Maher

Green Oracle <http://www.oracle.com/commitment> 	Oracle is committed to
developing practices and products that help protect the environment





More information about the vbox-dev mailing list