[vbox-dev] vboxbow not working?

Ramshankar ramshankar.venkataraman at oracle.com
Wed Jan 11 09:26:06 PST 2012


On 01/11/12 09:22 AM, Willi Burmeister wrote:
> Hi Ramshankar,
>
>>> For VirtualBox I created a new VNIC with:
>>>
>>> # dladm create-vnic -l igb1 -v 110 sun110001
>>>
>>>    110001 = VLAN-ID * 1000 + PPA
>>
>> iirc, with S11, I don't think you need to specify a PPA-hack name
>> anymore for VLANs.
>
> Chapter 6.4 (Bridge Networking) tells us:
>
> ----------------------------------------------------------------------
> When using VLAN interfaces with VirtualBox, they must be named according
> to the PPA-hack naming scheme (e.g. "e1000g513001"), as otherwise the
> guest may receive packets in an unexpected format.
> ----------------------------------------------------------------------
>>> Now I created a new VM with sun110001 as bridged interface and the same MAC address.
>>
>> You shouldn't have to manually assign the same MAC address anymore
>> with vboxbow. Simply passing the VNIC should be sufficient.
>
> Again chapter 6.4
>
> ----------------------------------------------------------------------
>    - The VNIC and the guest network interface that uses the VNIC must be
>      assigned identical MAC addresses.
> ----------------------------------------------------------------------
>
> Maybe the manual has be corrected as for vboxnow?

Yes, that only applied to older STREAMS vboxflt driver. Starting with 
VirtualBox 4.1.x and S11 hosts the newer vboxbow driver is used making 
all that obsolete. I forgot to update these parts of the documentation, 
I'll update it shortly. Thanks for the heads up.

>> Have you tried using a VirtualBox VLAN VNIC template? See User
>> Manual chapter 9.16 VirtualBox VNIC templates for VLANs on Solaris
>
> Now I have and all works ok now.

Great.

> Thanks for your answer.
>
> Greetings
>
> Willi
>
>
>





More information about the vbox-dev mailing list