[vbox-dev] IEvent not triggering on some events ... ?

Nikolay Igotti nikolay.igotti at oracle.com
Thu Mar 24 12:23:21 PDT 2011


       Hi Joseph,

  I think you just hit an issue (aka bug) in VirtualBox - certain events 
not triggered when they should or could be triggered.
The only solution is to implement those.

Klaus, what do you think about when shall events firing  happen, do you 
have bit of time to look on that?

   Thanks,
      Nikolay



24.03.2011 17:45, Joseph Smith ?????:
>
> Hi,
>
> Was wondering if anyone has had an opportunity to give this some 
> thought and maybe have some suggestions or ideas to offer.
>
>
> Thanks,
> Joe
>
> ------------------------------------------------------------------------
> *From:* Joseph Smith <joseph1962smith at yahoo.com>
> *To:* vbox-dev at virtualbox.org
> *Sent:* Sat, March 19, 2011 11:11:12 PM
> *Subject:* [vbox-dev] IEvent not triggering on some events ... ?
>
>
> VBox Ver: 4.0.0 and 4.0.4
> Hosts: Win XP, openSuSE 11.2, Mac OS 10.6
> Guests: various
>
> I am using the VirtualBox webservice PHP APIs (via 
> vboxServiceWrappers.php). With the release of 4.0.x, I shifted my 
> solution approach from a heavy polling approach to the light-weight 
> IEvent approach.
>
> It appears there are some key events that are not being triggered.  
> For example, I do not receive the IMediumChanged and IMediumRegistered 
> events among some lesser important events that I don't quite need just 
> yet (e.g: IRuntimeErrorEvent).
>
> I do consistently receive the OnMachineRegistered, 
> OnMachineDataChanged, OnMachineStateChanged, OnGuestPropertyChanged, 
> OnEventSourceChanged, OnSessionStateChagned events and a few others.
>
> When I register the listner (EventSource::RegisterListener), I listen 
> for 'Any' events as described in the documentation and after handling 
> each event, I call  EventSource::EventProcessed.
>
> Does ver 4.0.x fire IMedium events ?  Any suggestions of what I might 
> be able to look for to determine what I might be doing incorrectly?
>
> Oh ... my application runs for weeks at a time without being restarted 
> and polls about every 3 seconds for events.  There are never any 
> events that are not processed.  Of the events I listed above, I 
> continue to receive those events when actions trigger them ... just 
> not getting many of the others listed in the enumerated VBoxEvent Type.
>
> Any suggestions are welcome.
>
>
> Thanks,
> Joe
>
>
>
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> http://vbox.innotek.de/mailman/listinfo/vbox-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20110324/da68466d/attachment-0001.html 


More information about the vbox-dev mailing list